Debian Security Advisory

DLA-1268-1 p7zip -- LTS security update

Date Reported:
02 Feb 2018
Affected Packages:
p7zip
Vulnerable:
Yes
Security database references:
In the Debian bugtracking system: Bug 888297.
In Mitre's CVE dictionary: CVE-2017-17969.
More information:

The p7zip package has a heap-based buffer overflow in the NCompress::NShrink::CDecoder::CodeReal method in 7-Zip which allows remote attackers to cause a denial of service (out-of-bounds write) or potentially execute arbitrary code via a crafted ZIP archive.

For Debian 7 Wheezy, these problems have been fixed in version 9.20.1~dfsg.1-4+deb7u3.

We recommend that you upgrade your p7zip packages.

Further information about Debian LTS security advisories, how to apply these updates to your system and frequently asked questions can be found at: https://wiki.debian.org/LTS