Debian Security Advisory

DLA-1271-1 postgresql-9.1 -- LTS security update

Date Reported:
07 Feb 2018
Affected Packages:
postgresql-9.1
Vulnerable:
Yes
Security database references:
In Mitre's CVE dictionary: CVE-2018-1053.
More information:

A vulnerabilities has been found in the PostgreSQL database system:

  • CVE-2018-1053

    Tom Lane discovered that pg_upgrade, a tool used to upgrade PostgreSQL database clusters, creates temporary files containing password hashes that are world-readable.

For Debian 7 Wheezy, this problem has been fixed in version 9.1.24lts2-0+deb7u2.

We recommend that you upgrade your postgresql-9.1 packages.

Further information about Debian LTS security advisories, how to apply these updates to your system and frequently asked questions can be found at: https://wiki.debian.org/LTS