Debian Security Advisory

DLA-1273-1 simplesamlphp -- LTS security update

Date Reported:
09 Feb 2018
Affected Packages:
Security database references:
In the Debian bugtracking system: Bug 889286.
In Mitre's CVE dictionary: CVE-2017-18121, CVE-2017-18122, CVE-2018-6521.
More information:

simplesamlphp, an authentication and federation application has been found vulnerable to Cross Site Scripting (XSS), signature validation byepass and using insecure connection charset.

  • CVE-2017-18121

    A Cross Site Scripting (XSS) issue has been found in the consentAdmin module of SimpleSAMLphp through 1.14.15, allowing an attacker to manually craft links that a victim can open, executing arbitrary javascript code.

  • CVE-2017-18122

    A signature-validation bypass issue was discovered in SimpleSAMLphp through 1.14.16. Service Provider using SAML 1.1 will regard as valid any unsigned SAML response containing more than one signed assertion, provided that the signature of at least one of the assertions is valid. Attributes contained in all the assertions received will be merged and the entityID of the first assertion received will be used, allowing an attacker to impersonate any user of any IdP given an assertion signed by the targeted IdP.

  • CVE-2018-6521

    The sqlauth module in SimpleSAMLphp before 1.15.2 relies on the MySQL utf8 charset, which truncates queries upon encountering four-byte characters. There might be a scenario in which this allows remote attackers to bypass intended access restrictions.

For Debian 7 Wheezy, these problems have been fixed in version 1.9.2-1+deb7u2.

We recommend that you upgrade your simplesamlphp packages.

Further information about Debian LTS security advisories, how to apply these updates to your system and frequently asked questions can be found at: