Debian Security Advisory

DLA-1302-1 leptonlib -- LTS security update

Date Reported:
07 Mar 2018
Affected Packages:
leptonlib
Vulnerable:
Yes
Security database references:
In the Debian bugtracking system: Bug 890548, Bug 891932.
In Mitre's CVE dictionary: CVE-2018-7186, CVE-2018-7440.
More information:

Different flaws have been found in leptonlib, an image processing library.

  • CVE-2018-7186

    Leptonica did not limit the number of characters in a %s format argument to fscanf or sscanf, that made it possible to remote attackers to cause a denial of service (stack-based buffer overflow) or possibly have unspecified other impact via a long string.

  • CVE-2018-7440

    The gplotMakeOutput function allowed command injection via a approach in the gplot rootname argument. This issue existed because of an incomplete fix for CVE-2018-3836.

For Debian 7 Wheezy, these problems have been fixed in version 1.69-3.1+deb7u2.

We recommend that you upgrade your leptonlib packages.

Further information about Debian LTS security advisories, how to apply these updates to your system and frequently asked questions can be found at: https://wiki.debian.org/LTS