Debian Security Advisory

DLA-1322-1 graphicsmagick -- LTS security update

Date Reported:
28 Mar 2018
Affected Packages:
graphicsmagick
Vulnerable:
Yes
Security database references:
In Mitre's CVE dictionary: CVE-2017-18219, CVE-2017-18220, CVE-2017-18229, CVE-2017-18230, CVE-2017-18231, CVE-2018-9018.
More information:

Various security issues were discovered in Graphicsmagick, a collection of image processing tools.

  • CVE-2017-18219

    An allocation failure vulnerability was found in the function ReadOnePNGImage in coders/png.c, which allows attackers to cause a denial of service via a crafted file that triggers an attempt at a large png_pixels array allocation.

  • CVE-2017-18220

    The ReadOneJNGImage and ReadJNGImage functions in coders/png.c allow remote attackers to cause a denial of service or possibly have unspecified other impact via a crafted file, a related issue to CVE-2017-11403.

  • CVE-2017-18229

    An allocation failure vulnerability was found in the function ReadTIFFImage in coders/tiff.c, which allows attackers to cause a denial of service via a crafted file, because file size is not properly used to restrict scanline, strip, and tile allocations.

  • CVE-2017-18230

    A NULL pointer dereference vulnerability was found in the function ReadCINEONImage in coders/cineon.c, which allows attackers to cause a denial of service via a crafted file.

  • CVE-2017-18231

    A NULL pointer dereference vulnerability was found in the function ReadEnhMetaFile in coders/emf.c, which allows attackers to cause a denial of service via a crafted file.

  • CVE-2018-9018

    There is a divide-by-zero error in the ReadMNGImage function of coders/png.c. Remote attackers could leverage this vulnerability to cause a crash and denial of service via a crafted mng file.

For Debian 7 Wheezy, these problems have been fixed in version 1.3.16-1.1+deb7u19.

We recommend that you upgrade your graphicsmagick packages.

Further information about Debian LTS security advisories, how to apply these updates to your system and frequently asked questions can be found at: https://wiki.debian.org/LTS