Debian Security Advisory

DLA-1328-1 xerces-c -- LTS security update

Date Reported:
29 Mar 2018
Affected Packages:
xerces-c
Vulnerable:
Yes
Security database references:
In the Debian bugtracking system: Bug 894050.
In Mitre's CVE dictionary: CVE-2017-12627.
More information:

Alberto Garcia, Francisco Oca and Suleman Ali of Offensive Research discovered that the Xerces-C XML parser mishandles certain kinds of external DTD references, resulting in dereference of a NULL pointer while processing the path to the DTD. The bug allows for a denial of service attack in applications that allow DTD processing and do not prevent external DTD usage, and could conceivably result in remote code execution.

For Debian 7 Wheezy, these problems have been fixed in version 3.1.1-3+deb7u5.

We recommend that you upgrade your xerces-c packages.

Further information about Debian LTS security advisories, how to apply these updates to your system and frequently asked questions can be found at: https://wiki.debian.org/LTS