Bulletin d'alerte Debian

DLA-1328-1 xerces-c -- Mise à jour de sécurité pour LTS

Date du rapport :
29 mars 2018
Paquets concernés :
xerces-c
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le système de suivi des bogues Debian : Bogue 894050.
Dans le dictionnaire CVE du Mitre : CVE-2017-12627.
Plus de précisions :

Alberto Garcia, Francisco Oca et Suleman Ali de Offensive Research ont découvert que l’analyseur XML Xerces-C gère incorrectement certaines sortes de références DTD externes, aboutissant à un déréférencement de pointeur NULL lors du traitement du chemin vers la DTD. Ce bogue permet une attaque par déni de service dans les applications qui permettent le traitement de DTD et n’empêchent pas l’utilisation de DTD externes, et pourrait probablement aboutir à une exécution de code à distance.

Pour Debian 7 Wheezy, ces problèmes ont été corrigés dans la version 3.1.1-3+deb7u5.

Nous vous recommandons de mettre à jour vos paquets xerces-c.

Plus d’informations à propos des annonces de sécurité de Debian LTS, comment appliquer ces mises à jour dans votre système et les questions fréquemment posées peuvent être trouvées sur : https://wiki.debian.org/LTS.