Debian Security Advisory

DLA-1400-2 tomcat7 -- LTS security update

Date Reported:
01 Jul 2018
Affected Packages:
tomcat7
Vulnerable:
Yes
Security database references:
In the Debian bugtracking system: Bug 902670.
More information:

The security update of Tomcat 7 announced as DLA-1400-1 introduced a regression for applications that make use of the Equinox OSGi framework. The MANIFEST file of tomcat-jdbc.jar in libtomcat7-java contains an invalid version number which was automatically derived from the Debian package version. This caused an OSGi exception.

For Debian 8 Jessie, this issue has been fixed in version 7.0.56-3+really7.0.88-2.

We recommend that you upgrade your tomcat7 packages.

Further information about Debian LTS security advisories, how to apply these updates to your system and frequently asked questions can be found at: https://wiki.debian.org/LTS