Bulletin d'alerte Debian

DLA-1589-1 icecast2 -- Mise à jour de sécurité pour LTS

Date du rapport :
26 novembre 2018
Paquets concernés :
icecast2
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le système de suivi des bogues Debian : Bogue 914393.
Dans le dictionnaire CVE du Mitre : CVE-2018-19115.
Plus de précisions :

keepalived possédait un dépassement de tampon basé sur le tas lors de l’analyse des codes d’état HTTP. Cela menait à un déni de service ou éventuellement à un autre impact non précisé, parce que extract_status_code dans lib/html.c n’avait pas de validation du code d’état et à la place écrivait un montant illimité de données dans le tas.

Pour Debian 8 Jessie, ce problème a été corrigé dans la version 1:1.2.13-1+deb8u1.

Nous vous recommandons de mettre à jour vos paquets keepalived.

Plus d’informations à propos des annonces de sécurité de Debian LTS, comment appliquer ces mises à jour dans votre système et les questions fréquemment posées peuvent être trouvées sur : https://wiki.debian.org/LTS.