Bulletin d'alerte Debian

DLA-1597-1 gnuplot -- Mise à jour de sécurité pour LTS

Date du rapport :
26 novembre 2018
Paquets concernés :
gnuplot
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le dictionnaire CVE du Mitre : CVE-2018-19490, CVE-2018-19491, CVE-2018-19492.
Plus de précisions :

Gnuplot, un programme de tracé interactif en LDC, a été étudié avec des tests à données aléatoires par Tim Blazytko, Cornelius Aschermann, Sergej Schumilo et Nils Bars. Ils ont trouvé divers cas de dépassement qui pourraient aboutir à l'exécution de code arbitraire.

À cause de la chaîne de compilation spéciale pour durcissement dans Debian, CVE-2018-19492 ne concerne pas la sécurité, mais est un bogue et le correctif à été appliqué par souci d'exhaustivité. Probablement, quelques projets aval n’ont pas les mêmes réglages de chaîne de compilation.

Pour Debian 8 Jessie, ces problèmes ont été corrigés dans la version 4.6.6-2+deb8u1.

Nous vous recommandons de mettre à jour vos paquets gnuplot.