Bulletin d'alerte Debian

DLA-1614-1 openjpeg2 -- Mise à jour de sécurité pour LTS

Date du rapport :
22 décembre 2018
Paquets concernés :
openjpeg2
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le système de suivi des bogues Debian : Bogue 904873, Bogue 889683.
Dans le dictionnaire CVE du Mitre : CVE-2018-6616, CVE-2018-14423.
Plus de précisions :

Plusieurs vulnérabilités ont été découvertes dans openjpeg2, le codec JPEG 2000 au source ouvert.

  • CVE-2018-6616

    Itération excessive dans la fonction opj_t1_encode_cblks (openjp2/t1.c). Des attaquants distants pourraient exploiter cette vulnérabilité pour provoquer un déni de service à l'aide d'un fichier bmp contrefait.

  • CVE-2018-14423

    Vulnérabilités de division par zéro dans les fonctions pi_next_pcrl, pi_next_cprl et pi_next_rpcl dans (lib/openjp3d/pi.c). Des attaquants distants pourraient exploiter cette vulnérabilité pour provoquer un déni de service (plantage d'application).

Pour Debian 8 Jessie, ces problèmes ont été corrigés dans la version 2.1.0-2+deb8u6.

Nous vous recommandons de mettre à jour vos paquets openjpeg2.

Plus d’informations à propos des annonces de sécurité de Debian LTS, comment appliquer ces mises à jour dans votre système et les questions fréquemment posées peuvent être trouvées sur : https://wiki.debian.org/LTS.