Debian Security Advisory

DLA-1737-1 pdns -- LTS security update

Date Reported:
29 Mar 2019
Affected Packages:
pdns
Vulnerable:
Yes
Security database references:
In the Debian bugtracking system: Bug 924966.
In Mitre's CVE dictionary: CVE-2019-3871.
More information:

A vulnerability was found in PowerDNS Authoritative Server before 4.0.7 and before 4.1.7. An insufficient validation of data coming from the user when building a HTTP request from a DNS query in the HTTP Connector of the Remote backend, allowing a remote user to cause a denial of service by making the server connect to an invalid endpoint, or possibly information disclosure by making the server connect to an internal endpoint and somehow extracting meaningful information about the response.

Only installations using the pdns-backend-remote package are affected.

For Debian 8 Jessie, this problem has been fixed in version 3.4.1-4+deb8u9.

We recommend that you upgrade your pdns packages.

Further information about Debian LTS security advisories, how to apply these updates to your system and frequently asked questions can be found at: https://wiki.debian.org/LTS