Bulletin d'alerte Debian

DLA-1737-1 pdns -- Mise à jour de sécurité pour LTS

Date du rapport :
29 mars 2019
Paquets concernés :
pdns
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le système de suivi des bogues Debian : Bogue 924966.
Dans le dictionnaire CVE du Mitre : CVE-2019-3871.
Plus de précisions :

Une vulnérabilité a été découverte dans le serveur faisant autorité, PowerDNS, dans les versions avant 4.0.7 et avant 4.1.7. Une validation insuffisante des données provenant de l’utilisateur lors de la construction d’une requête HTTP issue d’une requête DNS dans le connecteur HTTP du dorsal distant, permettait à un utilisateur distant de provoquer un déni de service en faisant que le serveur se connecte à un nœud non valable, ou, éventuellement, une divulgation d'informations en faisant que le serveur se connecte à un nœud interne et extrayant de quelque façon des informations significatives à propos de la réponse.

Seules les installations utilisant le paquet pdns-backend-remote sont touchées.

Pour Debian 8 Jessie, ce problème a été corrigé dans la version 3.4.1-4+deb8u9.

Nous vous recommandons de mettre à jour vos paquets pdns.

Plus d’informations à propos des annonces de sécurité de Debian LTS, comment appliquer ces mises à jour dans votre système et les questions fréquemment posées peuvent être trouvées sur : https://wiki.debian.org/LTS.