Debian Security Advisory

DLA-1793-1 dhcpcd5 -- LTS security update

Date Reported:
19 May 2019
Affected Packages:
dhcpcd5
Vulnerable:
Yes
Security database references:
In Mitre's CVE dictionary: CVE-2019-11579.
More information:

It was discovered that there was a read overflow vulnerability in the dhcpcd5 network management protocol client.

  • CVE-2019-11579

    dhcp.c in dhcpcd before 7.2.1 contains a 1-byte read overflow with DHO_OPTSOVERLOADED.

For Debian 8 Jessie, these problems have been fixed in version 6.0.5-2+deb8u1. Thanks to Roy Marples <roy@marples.name>.

We recommend that you upgrade your dhcpcd5 packages.

Further information about Debian LTS security advisories, how to apply these updates to your system and frequently asked questions can be found at: https://wiki.debian.org/LTS