Debian Security Advisory

DLA-1855-1 exiv2 -- LTS security update

Date Reported:
19 Jul 2019
Affected Packages:
exiv2
Vulnerable:
Yes
Security database references:
In Mitre's CVE dictionary: CVE-2019-13504.
More information:

It was discovered that there was an integer overflow vulnerability in exiv2, a tool to manipulate images containing (eg.) EXIF metadata.

This could have resulted in a denial of service via a specially-crafted file.

  • CVE-2019-13504

    Out-of-bounds read in Exiv2::MrwImage::readMetadata in mrwimage.cpp in Exiv2 through 0.27.2.

For Debian 8 Jessie, these problems have been fixed in version 0.24-4.1+deb8u4.

We recommend that you upgrade your exiv2 packages.

Further information about Debian LTS security advisories, how to apply these updates to your system and frequently asked questions can be found at: https://wiki.debian.org/LTS