Bulletin d'alerte Debian

DLA-1956-1 ruby-openid -- Mise à jour de sécurité pour LTS

Date du rapport :
11 octobre 2019
Paquets concernés :
ruby-openid
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le dictionnaire CVE du Mitre : CVE-2019-11027.
Plus de précisions :

Ruby-openid réalisait d’abord la reconnaissance et ensuite la vérification. Cela permettait à un attaquant de modifier l’URL utilisée pour la reconnaissance et piéger le serveur pour se connecter à cette URL. Ce serveur à son tour pourrait être un serveur privé non accessible publiquement.

De plus, si le client qui utilise cette bibliothèque divulgue les erreurs de connexion, cela à son tour pourrait divulguer des informations du serveur privé à l’attaquant.

Pour Debian 8 Jessie, ce problème a été corrigé dans la version 2.5.0debian-1+deb8u1.

Nous vous recommandons de mettre à jour vos paquets ruby-openid.

Plus d’informations à propos des annonces de sécurité de Debian LTS, comment appliquer ces mises à jour dans votre système et les questions fréquemment posées peuvent être trouvées sur : https://wiki.debian.org/LTS.