Debian Security Advisory

DLA-1973-1 libxslt -- LTS security update

Date Reported:
27 Oct 2019
Affected Packages:
libxslt
Vulnerable:
Yes
Security database references:
In the Debian bugtracking system: Bug 942646.
In Mitre's CVE dictionary: CVE-2019-18197.
More information:

A security vulnerability was discovered in libxslt, a XSLT 1.0 processing library written in C.

In xsltCopyText in transform.c, a pointer variable is not reset under certain circumstances. If the relevant memory area happened to be freed and reused in a certain way, a bounds check could fail and memory outside a buffer could be written to, or uninitialized data could be disclosed.

For Debian 8 Jessie, this problem has been fixed in version 1.1.28-2+deb8u6.

We recommend that you upgrade your libxslt packages.

Further information about Debian LTS security advisories, how to apply these updates to your system and frequently asked questions can be found at: https://wiki.debian.org/LTS