Bulletin d'alerte Debian

DLA-2011-1 xmlrpc-epi -- Mise à jour de sécurité pour LTS

Date du rapport :
26 novembre 2019
Paquets concernés :
xmlrpc-epi
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le dictionnaire CVE du Mitre : CVE-2016-6296.
Plus de précisions :

Un problème dans xmlrpc-epi, une bibliothèque de sérialisation et désérialisation de requête XML-RPC, a été découvert.

Une erreur de signe d’entier dans la fonction simplestring_addn dans simplestring.c dans xmlrpc-epi pourrait être utilisée pour un dépassement de tampon basé sur le tas et éventuellement une exécution de code arbitraire.

Pour Debian 8 Jessie, ce problème a été corrigé dans la version 0.54.2-1.1+deb8u1.

Nous vous recommandons de mettre à jour vos paquets xmlrpc-epi.

Plus d’informations à propos des annonces de sécurité de Debian LTS, comment appliquer ces mises à jour dans votre système et les questions fréquemment posées peuvent être trouvées sur : https://wiki.debian.org/LTS.