Bulletin d'alerte Debian

DLA-2143-1 slurm-llnl -- Mise à jour de sécurité pour LTS

Date du rapport :
16 mars 2020
Paquets concernés :
slurm-llnl
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le système de suivi des bogues Debian : Bogue 920997, Bogue 931880.
Dans le dictionnaire CVE du Mitre : CVE-2019-6438, CVE-2019-12838.
Plus de précisions :

Plusieurs problèmes ont été trouvés dans SLURM (Simple Linux Utility for Resource Management), un système de gestion de ressources et de planification de travaux pour l’informatique dématérialisée.

  • CVE-2019-6438

    SchedMD Slurm gère incorrectement les systèmes 32 bits, provoquant un dépassement de tas dans xmalloc.

  • CVE-2019-12838

    SchedMD Slurm ne protège pas les chaînes lors de l’importation d’un fichier d’archive dans le dorsal pour accounting_storage/mysql, aboutissant à une injection SQL.

Pour Debian 8 Jessie, ces problèmes ont été corrigés dans la version 14.03.9-5+deb8u5.

Nous vous recommandons de mettre à jour vos paquets slurm-llnl.

Plus d’informations à propos des annonces de sécurité de Debian LTS, comment appliquer ces mises à jour dans votre système et les questions fréquemment posées peuvent être trouvées sur : https://wiki.debian.org/LTS.