Debian Security Advisory

DLA-2192-1 ruby2.1 -- LTS security update

Date Reported:
01 May 2020
Affected Packages:
Security database references:
In Mitre's CVE dictionary: CVE-2020-10663.
More information:

The JSON gem through 2.2.0 for Ruby, as used in Ruby 2.1 has an unsafe object creation vulnerability. This is quite similar to CVE-2013-0269, but does not rely on poor garbage-collection behavior within Ruby. Specifically, use of JSON parsing methods can lead to creation of a malicious object within the interpreter, with adverse effects that are application-dependent.

For Debian 8 Jessie, this problem has been fixed in version 2.1.5-2+deb8u10.

We recommend that you upgrade your ruby2.1 packages.

Further information about Debian LTS security advisories, how to apply these updates to your system and frequently asked questions can be found at: