Debian Security Advisory

DLA-2307-1 ruby-zip -- LTS security update

Date Reported:
02 Aug 2020
Affected Packages:
Security database references:
In the Debian bugtracking system: Bug 902720.
In Mitre's CVE dictionary: CVE-2018-1000544.
More information:

rubyzip gem version 1.2.1 and earlier contains a Directory Traversal vulnerability in Zip::File component that can result in write arbitrary files to the filesystem.

This attack appear to be exploitable via if a site allows uploading of .zip files, an attacker can upload a malicious file that contains symlinks or files with absolute pathnames "../" to write arbitrary files to the filesystem..

For Debian 9 stretch, this problem has been fixed in version 1.2.0-1.1+deb9u1.

We recommend that you upgrade your ruby-zip packages.

For the detailed security status of ruby-zip please refer to its security tracker page at:

Further information about Debian LTS security advisories, how to apply these updates to your system and frequently asked questions can be found at: