Debian Security Advisory
DLA-2308-1 libopenmpt -- LTS security update
- Date Reported:
- 02 Aug 2020
- Affected Packages:
- Security database references:
- In Mitre's CVE dictionary: CVE-2019-17113.
- More information:
In libopenmpt before 0.3.19 and 0.4.x before 0.4.9, ModPlug_InstrumentName and ModPlug_SampleName in libopenmpt_modplug.c do not restrict the lengths of libmodplug output-buffer strings in the C API, leading to a buffer overflow.
For Debian 9 stretch, this problem has been fixed in version 0.2.7386~beta20.3-3+deb9u4.
We recommend that you upgrade your libopenmpt packages.
For the detailed security status of libopenmpt please refer to its security tracker page at: https://security-tracker.debian.org/tracker/libopenmpt
Further information about Debian LTS security advisories, how to apply these updates to your system and frequently asked questions can be found at: https://wiki.debian.org/LTS