Debian Security Advisory

DLA-2365-1 netty-3.9 -- LTS security update

Date Reported:
04 Sep 2020
Affected Packages:
Security database references:
In the Debian bugtracking system: Bug 941266, Bug 950966, Bug 950967.
In Mitre's CVE dictionary: CVE-2019-16869, CVE-2019-20444, CVE-2019-20445.
More information:

Several vulnerabilities have been discovered in netty-3.9, a Java NIO client/server socket framework.

  • CVE-2019-16869

    Netty before 4.1.42.Final mishandles whitespace before the colon in HTTP headers (such as a "Transfer-Encoding : chunked" line), which leads to HTTP request smuggling.

  • CVE-2019-20444 in Netty before 4.1.44 allows an HTTP header that lacks a colon, which might be interpreted as a separate header with an incorrect syntax, or might be interpreted as an "invalid fold."

  • CVE-2019-20445 in Netty before 4.1.44 allows a Content-Length header to be accompanied by a second Content-Length header, or by a Transfer-Encoding header.

For Debian 9 stretch, these problems have been fixed in version 3.9.9.Final-1+deb9u1.

We recommend that you upgrade your netty-3.9 packages.

For the detailed security status of netty-3.9 please refer to its security tracker page at:

Further information about Debian LTS security advisories, how to apply these updates to your system and frequently asked questions can be found at: