Debian Security Advisory

DLA-2372-1 libproxy -- LTS security update

Date Reported:
12 Sep 2020
Affected Packages:
Security database references:
In Mitre's CVE dictionary: CVE-2020-25219.
More information:

It was discovered that there was a denial of service attack in libproxy, a library to make applications HTTP proxy aware. A remote server could cause an infinite stack recursion.

  • CVE-2020-25219

    url::recvline in url.cpp in libproxy 0.4.x through 0.4.15 allows a remote HTTP server to trigger uncontrolled recursion via a response composed of an infinite stream that lacks a newline character. This leads to stack exhaustion.

For Debian 9 Stretch, these problems have been fixed in version 0.4.14-2+deb9u1.

We recommend that you upgrade your libproxy packages.

Further information about Debian LTS security advisories, how to apply these updates to your system and frequently asked questions can be found at: