Bulletin d'alerte Debian

DLA-2405-1 httpcomponents-client -- Mise à jour de sécurité pour LTS

Date du rapport :
10 octobre 2020
Paquets concernés :
httpcomponents-client
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le dictionnaire CVE du Mitre : CVE-2020-13956.
Plus de précisions :

Oleg Kalnichevski a découvert que httpcomponents-client, une bibliothèque Java pour construire des applications concernées par HTTP, pouvait mal interpréter un composant d’autorité mal formé dans des URI de requête passés à la bibliothèque comme objets java.net.URI et choisir le mauvais hôte cible pour l’exécution des requêtes.

Pour Debian 9 Stretch, ce problème a été corrigé dans la version 4.5.2-2+deb9u1.

Nous vous recommandons de mettre à jour vos paquets httpcomponents-client.

Pour disposer d'un état détaillé sur la sécurité de httpcomponents-client, veuillez consulter sa page de suivi de sécurité à l'adresse : https://security-tracker.debian.org/tracker/httpcomponents-client.

Plus d’informations à propos des annonces de sécurité de Debian LTS, comment appliquer ces mises à jour dans votre système et les questions fréquemment posées peuvent être trouvées sur : https://wiki.debian.org/LTS.