Debian Security Advisory

DLA-2427-1 spice -- LTS security update

Date Reported:
01 Nov 2020
Affected Packages:
Security database references:
In the Debian bugtracking system: Bug 971750.
In Mitre's CVE dictionary: CVE-2020-14355.
More information:

Multiple buffer overflow vulnerabilities were found in the QUIC image decoding process of the SPICE remote display system, before spice-0.14.2-1.

Both the SPICE client (spice-gtk) and server are affected by these flaws. These flaws allow a malicious client or server to send specially crafted messages that, when processed by the QUIC image compression algorithm, result in a process crash or potential code execution.

For Debian 9 stretch, this problem has been fixed in version 0.12.8-2.1+deb9u4.

We recommend that you upgrade your spice packages.

For the detailed security status of spice please refer to its security tracker page at:

Further information about Debian LTS security advisories, how to apply these updates to your system and frequently asked questions can be found at: