Debian Security Advisory

DLA-2490-1 x11vnc -- LTS security update

Date Reported:
10 Dec 2020
Affected Packages:
x11vnc
Vulnerable:
Yes
Security database references:
In Mitre's CVE dictionary: CVE-2020-29074.
More information:

Guenal Davalan reported a flaw in x11vnc, a VNC server to allow remote access to an existing X session. x11vnc creates shared memory segments with 0777 mode. A local attacker can take advantage of this flaw for information disclosure, denial of service or interfering with the VNC session of another user on the host.

For Debian 9 stretch, this problem has been fixed in version 0.9.13-2+deb9u2.

We recommend that you upgrade your x11vnc packages.

For the detailed security status of x11vnc please refer to its security tracker page at: https://security-tracker.debian.org/tracker/x11vnc

Further information about Debian LTS security advisories, how to apply these updates to your system and frequently asked questions can be found at: https://wiki.debian.org/LTS