Bulletin d'alerte Debian

DLA-2536-1 libsdl2 -- Mise à jour de sécurité pour LTS

Date du rapport :
30 janvier 2021
Paquets concernés :
libsdl2
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le dictionnaire CVE du Mitre : CVE-2019-7575, CVE-2019-7577, CVE-2019-7578, CVE-2019-7635, CVE-2019-7636, CVE-2019-7638, CVE-2019-13616, CVE-2020-14409, CVE-2020-14410.
Plus de précisions :

Plusieurs problèmes ont été découverts dans libsdl2, une bibliothèque pour un accès de bas niveau au tampon de trame, à la sortie audio, à la souris et au clavier. Tous les problèmes concernent soit un dépassement de tampon, un dépassement d'entier ou une lecture hors limites de tampon de tas, aboutissant à un déni de service ou une exécution de code à distance en utilisant des fichiers contrefaits de différents formats.

Pour Debian 9 Stretch, ces problèmes ont été corrigés dans la version 2.0.5+dfsg1-2+deb9u1.

Nous vous recommandons de mettre à jour vos paquets libsdl2.

Pour disposer d'un état détaillé sur la sécurité de libsdl2, veuillez consulter sa page de suivi de sécurité à l'adresse : https://security-tracker.debian.org/tracker/libsdl2.

Plus d’informations à propos des annonces de sécurité de Debian LTS, comment appliquer ces mises à jour dans votre système et les questions fréquemment posées peuvent être trouvées sur : https://wiki.debian.org/LTS.