Bulletin d'alerte Debian

DLA-2741-1 commons-io -- Mise à jour de sécurité pour LTS

Date du rapport :
12 août 2021
Paquets concernés :
commons-io
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le dictionnaire CVE du Mitre : CVE-2021-29425.
Plus de précisions :

Lukas Euler a découvert une vulnérabilité de traversée de répertoires dans commons-io, une bibliothèque Java pour les classes couramment utiles et relatives à IO. Lors de l’invocation de la méthode FileNameUtils.normalize avec une chaîne d’entrée non conforme, telle que « //../foo » ou « \\..\foo », le résultat pourrait être la même valeur, par conséquent fournissant éventuellement un accès à des fichiers dans le répertoire parent, mais pas au-delà (donc traversée de répertoires limitée), si le code appelant utilise le résultat pour construire une valeur de chemin.

Pour Debian 9 « Stretch », ce problème a été corrigé dans la version 2.5-1+deb9u1.

Nous vous recommandons de mettre à jour vos paquets commons-io.

Pour disposer d'un état détaillé sur la sécurité de commons-io, veuillez consulter sa page de suivi de sécurité à l'adresse : https://security-tracker.debian.org/tracker/commons-io.

Plus d’informations à propos des annonces de sécurité de Debian LTS, comment appliquer ces mises à jour dans votre système et les questions fréquemment posées peuvent être trouvées sur : https://wiki.debian.org/LTS.