Debian Security Advisory

DLA-3015-1 ark -- LTS security update

Date Reported:
20 May 2022
Affected Packages:
ark
Vulnerable:
Yes
Security database references:
In the Debian bugtracking system: Bug 969437.
In Mitre's CVE dictionary: CVE-2020-16116, CVE-2020-24654.
More information:

Fabian Vogt and Dominik Penner discovered that the Ark archive manager did not sanitize extraction paths, which could result in maliciously crafted archives with symlinks writing outside the extraction directory.

For Debian 9 stretch, these problems have been fixed in version 4:16.08.3-2+deb9u1.

We recommend that you upgrade your ark packages.

For the detailed security status of ark please refer to its security tracker page at: https://security-tracker.debian.org/tracker/ark

Further information about Debian LTS security advisories, how to apply these updates to your system and frequently asked questions can be found at: https://wiki.debian.org/LTS