Debian Security Advisory

DLA-3025-1 irssi -- LTS security update

Date Reported:
26 May 2022
Affected Packages:
Security database references:
In Mitre's CVE dictionary: CVE-2019-13045.
More information:

It was discovered that there was a user-after-free vulnerability in irssi, the popular terminal-based IRC client.

  • CVE-2019-13045

    Irssi before 1.0.8, 1.1.x before 1.1.3, and 1.2.x before 1.2.1, when SASL is enabled, has a use after free when sending SASL login to the server.

For Debian 9 Stretch, these problems have been fixed in version 1.0.7-1~deb9u2.

We recommend that you upgrade your irssi packages.

Further information about Debian LTS security advisories, how to apply these updates to your system and frequently asked questions can be found at: