Debian Security Advisory

DLA-3084-1 ndpi -- LTS security update

Date Reported:
28 Aug 2022
Affected Packages:
ndpi
Vulnerable:
Yes
Security database references:
In Mitre's CVE dictionary: CVE-2020-15472, CVE-2020-15476.
More information:

Two security issues have been discovered in ndpi: deep packet inspection library.

  • CVE-2020-15472

    H.323 dissector is vulnerable to a heap-based buffer over-read in ndpi_search_h323 in lib/protocols/h323.c.

  • CVE-2020-15476

    Oracle protocol dissector has a heap-based buffer over-read in ndpi_search_oracle.

For Debian 10 buster, these problems have been fixed in version 2.6-3+deb10u1.

We recommend that you upgrade your ndpi packages.

For the detailed security status of ndpi please refer to its security tracker page at: https://security-tracker.debian.org/tracker/ndpi

Further information about Debian LTS security advisories, how to apply these updates to your system and frequently asked questions can be found at: https://wiki.debian.org/LTS