Debian Security Advisory

DLA-3100-1 libgoogle-gson-java -- LTS security update

Date Reported:
07 Sep 2022
Affected Packages:
libgoogle-gson-java
Vulnerable:
Yes
Security database references:
In the Debian bugtracking system: Bug 1010670.
In Mitre's CVE dictionary: CVE-2022-25647.
More information:

It was discovered that Gson, a Java library that can be used to convert Java Objects into their JSON representations and vice versa, was vulnerable to a deserialization flaw. An application would de-serialize untrusted data without sufficiently verifying that the resulting data will be valid, letting the attacker to control the state or the flow of the execution. This can lead to a denial of service or even the execution of arbitrary code.

For Debian 10 buster, this problem has been fixed in version 2.8.5-3+deb10u1.

We recommend that you upgrade your libgoogle-gson-java packages.

For the detailed security status of libgoogle-gson-java please refer to its security tracker page at: https://security-tracker.debian.org/tracker/libgoogle-gson-java

Further information about Debian LTS security advisories, how to apply these updates to your system and frequently asked questions can be found at: https://wiki.debian.org/LTS