Debian Security Advisory

DLA-3105-1 connman -- LTS security update

Date Reported:
13 Sep 2022
Affected Packages:
Security database references:
In Mitre's CVE dictionary: CVE-2022-32292, CVE-2022-32293.
More information:

It was discovered that there were two issues in connman, a daemon for managing internet connections within embedded devices:

  • CVE-2022-32292

    In ConnMan through 1.41, remote attackers able to send HTTP requests to the gweb component are able to exploit a heap-based buffer overflow in received_data to execute code.

  • CVE-2022-32292

    In ConnMan through 1.41, a man-in-the-middle attack against a WISPR HTTP query could be used to trigger a use-after-free in WISPR handling, leading to crashes or code execution.

For Debian 10 Buster, these problems have been fixed in version 1.36-2.1~deb10u3.

We recommend that you upgrade your connman packages.

Further information about Debian LTS security advisories, how to apply these updates to your system and frequently asked questions can be found at: