Debian Security Advisory

DLA-3124-1 webkit2gtk -- LTS security update

Date Reported:
29 Sep 2022
Affected Packages:
webkit2gtk
Vulnerable:
Yes
Security database references:
In Mitre's CVE dictionary: CVE-2022-32886.
More information:

The following vulnerabilities have been discovered in the WebKitGTK web engine:

  • CVE-2022-32886

    P1umer, afang5472 and xmzyshypnc discovered that processing maliciously crafted web content may lead to arbitrary code execution

For Debian 10 buster, this problem has been fixed in version 2.38.0-1~deb10u1.

We recommend that you upgrade your webkit2gtk packages.

For the detailed security status of webkit2gtk please refer to its security tracker page at: https://security-tracker.debian.org/tracker/webkit2gtk

Further information about Debian LTS security advisories, how to apply these updates to your system and frequently asked questions can be found at: https://wiki.debian.org/LTS