Debian Security Advisory

DLA-3146-1 isc-dhcp -- LTS security update

Date Reported:
11 Oct 2022
Affected Packages:
isc-dhcp
Vulnerable:
Yes
Security database references:
In the Debian bugtracking system: Bug 1021320.
In Mitre's CVE dictionary: CVE-2022-2928, CVE-2022-2929.
More information:

Several vulnerabilities have been discovered in the ISC DHCP client, relay and server.

  • CVE-2022-2928

    It was discovered that the DHCP server does not correctly perform option reference counting when configured with "allow leasequery;". A remote attacker can take advantage of this flaw to cause a denial of service (daemon crash).

  • CVE-2022-2929

    It was discovered that the DHCP server is prone to a memory leak flaw when handling contents of option 81 (fqdn) data received in a DHCP packet. A remote attacker can take advantage of this flaw to cause DHCP servers to consume resources, resulting in denial of service.

For Debian 10 buster, these problems have been fixed in version 4.4.1-2+deb10u2.

We recommend that you upgrade your isc-dhcp packages.

For the detailed security status of isc-dhcp please refer to its security tracker page at: https://security-tracker.debian.org/tracker/isc-dhcp

Further information about Debian LTS security advisories, how to apply these updates to your system and frequently asked questions can be found at: https://wiki.debian.org/LTS