Debian Security Advisory

DLA-3147-1 twig -- LTS security update

Date Reported:
11 Oct 2022
Affected Packages:
twig
Vulnerable:
Yes
Security database references:
In Mitre's CVE dictionary: CVE-2022-39261.
More information:

It was discovered that there was a potential arbitrary file read vulnerability in twig, a PHP templating library. It was caused by insufficient validation of template names in 'source' and 'include' statements.

  • CVE-2022-39261

    Twig is a template language for PHP. Versions 1.x prior to 1.44.7, 2.x prior to 2.15.3, and 3.x prior to 3.4.3 encounter an issue when the filesystem loader loads templates for which the name is a user input. It is possible to use the `source` or `include` statement to read arbitrary files from outside the templates' directory when using a namespace like `@somewhere/../some.file`. In such a case, validation is bypassed. Versions 1.44.7, 2.15.3, and 3.4.3 contain a fix for validation of such template names. There are no known workarounds aside from upgrading.

For Debian 10 Buster, this problem has been fixed in version 2.6.2-2+deb10u1.

We recommend that you upgrade your twig packages.

Further information about Debian LTS security advisories, how to apply these updates to your system and frequently asked questions can be found at: https://wiki.debian.org/LTS