Debian Security Advisory

DLA-3168-1 openvswitch -- LTS security update

Date Reported:
29 Oct 2022
Affected Packages:
openvswitch
Vulnerable:
Yes
Security database references:
In Mitre's CVE dictionary: CVE-2022-32166.
More information:

An issue has been found in openvswitch, a software-based, Ethernet virtual switch.

This issue is about a heap buffer over-read in flow.c, which could lead to access to an unmapped region of memory. This could result in crashing the software, memory modification, or possible remote execution.

For Debian 10 buster, this problem has been fixed in version 2.10.7+ds1-0+deb10u2.

We recommend that you upgrade your openvswitch packages.

For the detailed security status of openvswitch please refer to its security tracker page at: https://security-tracker.debian.org/tracker/openvswitch

Further information about Debian LTS security advisories, how to apply these updates to your system and frequently asked questions can be found at: https://wiki.debian.org/LTS