Debian Security Advisory

DLA-3175-1 python3.7 -- LTS security update

Date Reported:
01 Nov 2022
Affected Packages:
python3.7
Vulnerable:
Yes
Security database references:
In Mitre's CVE dictionary: CVE-2022-37454.
More information:

Nicky Mouha discovered a buffer overflow in _sha3, the SHA-3 hashing function module used by hashlib in Python 3.7.

While the attacks require a large volume of data, they could potentially result in remote code execution.

For Debian 10 buster, this problem has been fixed in version 3.7.3-2+deb10u4.

We recommend that you upgrade your python3.7 packages.

For the detailed security status of python3.7 please refer to its security tracker page at: https://security-tracker.debian.org/tracker/python3.7

Further information about Debian LTS security advisories, how to apply these updates to your system and frequently asked questions can be found at: https://wiki.debian.org/LTS