Debian Security Advisory

DLA-3191-1 python-django -- LTS security update

Date Reported:
17 Nov 2022
Affected Packages:
python-django
Vulnerable:
Yes
Security database references:
In Mitre's CVE dictionary: CVE-2021-45452, CVE-2022-22818, CVE-2022-23833.
More information:

Multiple issues were discovered in Django, a Python-based web development framework:

  • CVE-2021-45452

    Storage.save allowed directory traversal if crafted filenames were passed directlyto it.

  • CVE-2022-22818

    The {% debug %} template tag did not properly encode the current context. This may lead to a cross-site scripting (XSS) vulnerability.

  • CVE-2022-23833

    The HTTP MultiPartParser had a issue whereby certain inputs to multipart forms could result in an infinite loop when parsing uploaded files.

For Debian 10 Buster, these problems have been fixed in version 1:1.11.29-1+deb10u4.

We recommend that you upgrade your python-django packages.

Further information about Debian LTS security advisories, how to apply these updates to your system and frequently asked questions can be found at: https://wiki.debian.org/LTS