Debian 11 (bullseye), ARMv7 (EABI hard-float ABI) 的发行说明

Debian 文档项目

本文档是自由软件;您可以在自由软件基金会发布的 GNU 通用公共许可证的条款下重新发布或修改它;您应当使用该许可证的第二版本。

本程序发布的目的是希望它对您有用,但没有任何担保,甚至不保证它有经济价值和适合特定用途。请查阅 GNU 通用公共许可证以获得更多细节。

您应当在收到本程序的同时也收到了一份 GNU 通用公共许可证的副本;如果没有收到,请给自由软件基金会写信。地址是:51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.

协议文本可以在 https://www.gnu.org/licenses/gpl-2.0.html 和 Debian 系统中的 /usr/share/common-licenses/GPL-2 找到。


目录

1. 简介
1.1. 报告文档错误
1.2. 贡献升级报告
1.3. 本文档的源文件
2. Debian 11 的新变化
2.1. 支持的架构
2.2. 这次发布中有什么新变化?
3. 安装系统
3.1. 安装系统有哪些新特性?
3.1.1. 自动安装
4. 从 Debian 10(buster)升级
4.1. 升级前的准备
4.1.1. 备份数据和配置文件
4.1.2. 提前告知用户
4.1.3. 准备服务停机
4.1.4. 准备故障恢复
4.1.5. 为升级准备安全环境
4.2. Start from "pure" Debian
4.2.1. Upgrade to Debian 10 (buster)
4.2.2. Remove non-Debian packages
4.2.3. Upgrade to latest point release
4.2.4. Prepare the package database
4.2.5. Remove obsolete packages
4.2.6. Clean up leftover configuration files
4.2.7. proposed-updates 区
4.2.8. 非官方源
4.2.9. 禁用 APT pinning
4.2.10. Check package status
4.3. 准备 APT source-list 文件
4.3.1. 添加互联网 APT 源
4.3.2. 添加本地镜像 APT 源
4.3.3. 从光学介质中添加 APT 源
4.4. 升级软件包
4.4.1. 记录会话
4.4.2. 更新软件包列表
4.4.3. 确保您有足够的空间升级
4.4.4. 最小系统升级
4.4.5. 升级系统
4.5. 升级期间可能遇到的问题
4.5.1. Dist-upgrade 失败,显示无法立即配置
4.5.2. 预期的删除
4.5.3. 冲突或预依赖循环
4.5.4. 文件冲突
4.5.5. 配置文件变化
4.5.6. 将会话切换到控制台
4.6. 升级内核与相关包
4.6.1. 安装内核元软件包
4.7. 为下个发布版本做准备
4.7.1. 清理已删除的软件包
4.8. 过时的软件包
4.8.1. 过渡哑包
5. bullseye 中需要注意的问题
5.1. 升级到 bullseye 时可能出现的问题
5.1.1. New VA-API default driver for Intel GPUs
5.1.2. 值得注意的过时软件包
5.1.3. bullseye 的废弃组件
5.2. 安全支持上的局限性
5.3. 特定软件包的问题
5.3.1. Accessing GNOME Settings app without mouse
6. 关于 Debian 的更多信息
6.1. 扩展阅读
6.2. 获得帮助
6.2.1. 邮件列表
6.2.2. IRC
6.3. 报告 Bug
6.4. 为 Debian 做贡献
A. 在升级前管理您的 buster 系统
A.1. 升级您的 buster 系统
A.2. 检查您的 APT source-list 文件
A.3. 删除过时的配置文件
A.4. 将旧版区域设置升级为 UTF-8
B. 发行说明的贡献者
索引
术语表