Kapittel 5. Problemer du bør kjenne til vedrørende lenny

Innholdsfortegnelse

5.1. Potensielle problemer
5.1.1. Problemer med enheter i tillknytting til udev
5.1.2. Noen program vil ikke fungere med kjerne 2.4
5.1.3. Noen nettverkssteder kan ikke nåes via TCP
5.1.4. Automatisk avskruing slutter å virke
5.1.5. Asynkron initiering av nettverket kan forårsake uforutsette konsekvenser
5.1.6. Problemer med å bruke trådløse nettverk beskyttet med WPA
5.1.7. Problemer i filnavn med tegn som ikke er ASCII
5.1.8. Lyd stopper å virke
5.2. NFS monteringer håndters nå av nfs-common
5.3. Endringer i rumensk(ro) tastaturoppsett
5.4. Oppgradere apache2
5.5. NIS og Network Manager
5.6. Sikkerhetsstatus for Mozillaprodukter
5.7. Security status of OCS Inventory and SQL-Ledger
5.8. KDE skrivbordet
5.9. Støtte og endringer i Gnome skrivebordet
5.10. Ingen støtte for Unicode som standard i emacs21*
5.11. slurpd/replica vil ikke lenger fungere
5.12. Skrivebordet bruker ikke hele skjermen
5.13. DHCP problemer med feiltoleranse
5.14. VServer Disk Limit

5.1. Potensielle problemer

Noen ganger så vil endringer ha uønskede sideeffekter, eller de vil avdekke feil andre steder. Vi dokumenterer her alle slike problemer som vi kjenner til. Vennligst les avsnittet om skrivefeil, dokumentasjon for den aktuelle pakken, feilrapporter og annen informasjon nevnt i Seksjon 6.1, “Ytterligere lesing”.

5.1.1. Problemer med enheter i tillknytting til udev

Selv om udev har blitt testet grundig, så kan du oppleve mindre problemer med noen enheter som må fikses. Det vanligste er å måtte endre rettigheter og/eller eierskap på en enhet. I noen tilfeller så vil en enhet som standard ikke lages, f.eks /dev/video og /dev/radio

udev tilbyr mekanismer for å enkelt utføre disse konfigurasjonene. Se udev(8) og /etc/udev for mer informasjon.

5.1.2. Noen program vil ikke fungere med kjerne 2.4

Noen program som følger med lenny vil ikke virke med kjerne 2.4, ofte fordi de krever epoll() støtte, som ikke er tilgjengelig i kjerne 2.4. Slike program vil enten bare delvis virke, eller ikke virke i det hele tatt før systemet har blitt starter med en 2.6 kjerne.

Et slikt eksempel er HTTP proxy squid.

5.1.3. Noen nettverkssteder kan ikke nåes via TCP

Siden 2.6.17 kjernen så brukes vindusstørrelsen i TCP veldig aktivt i henhold til RFC 1323. Noen servere har feil innstillinger, og ber om feil vindusstørrelsen . Les mer om dette i #381262, #395066, #401435.

Det fins vanligvis to måter å komme seg rundt dette problemet: enten ved å endre den største tillatte vindusstørrelsen til en lavere verdi (anbefalt måte), eller ved å skru av TCP vindusstørrelse skallering(fases ut, bør ikke brukes). Se eksempel på kommandoer i debian-installer skrivefeil.

5.1.4. Automatisk avskruing slutter å virke

På en del eldre systemer så kan ikke kommendoen shutdown -h brukes for å skru av systemet lengre (systemet stopper bare opp). Dette skjer fordi APM må brukes på disse systemene. Ved å legge til acpi=off apm=power_off til kjernens kommandolinje i innstillingene i pakken grub eller lilo så vil de skru seg ordentlig av. Se feilrapport #390547 for mer informasjon.

5.1.5. Asynkron initiering av nettverket kan forårsake uforutsette konsekvenser

På system som bruker udev for å laste drivere for nettverkskort, så er det mulig at den asynkrone måten som udev kjører på, gjør at nettverkskortet ikke har blitt aktivert før /etc/init.d/networking starter under oppstart. Selv om det å legge til allow-hotplug i fila /etc/network/interfaces (i tillegg til auto) vil sørge for at nettverket kommer opp så snart nettverkskortet er aktivert, så er det ingen garanti for at dette skjer før oppstartsekvensen er over, en del tjenester som starter under oppstartsekvensen kan bli påvirket av dette.

5.1.6. Problemer med å bruke trådløse nettverk beskyttet med WPA

I etch var pakken wpasupplicant installert som en systemtjeneste med innstillinger lagret i /etc/default/wpasupplicant og med brukerspesifikke innstillinger lagret i /etc/wpasupplicant.conf.

I lenny, har /etc/init.d/wpasupplicant forsvunnet, og Debian pakken er nå integrert med /etc/network/interfaces, på samme måte som f.eks pakken wireless-tools. Dette betyr at wpasupplicant ikke lenger tilbyr noen systemtjeneste.

For mer informasjon om hvordan man skal konfigurere wpasupplicant , så les /usr/share/doc/wpasupplicant/README.modes.gz, der finner du eksempler på ulike oppsett av /etc/network/interfaces. Oppdatert informasjon på hvordan du skal bruke wpasupplicant pakken i Debian finner du på Debian Wiki.

5.1.7. Problemer i filnavn med tegn som ikke er ASCII

Montering av filsystemtypene vfat, ntfs eller iso9660 som inneholder tegn utenfor ASCII-tabellen fører til at feil oppstår når disse filene brukes, om man ikke har montert filsystemet med opsjonen utf8. Følgende melding kan være et slikt eksempel: “Invalid or incomplete multibyte or wide character”. En mulig løsning er å bruke defaults,utf8 som en opsjon ved montering av filsystemtypene vfat, ntfs eller iso9660 om disse inneholder filnavn med tegn fra utenfor ASCII-tabellen.

Merk at Linux-kjernen ikke har støtte for å ikke ta hensyn til store eller små bokstaver i filnavn for vfat filsystem når alternativet utf8 brukes.

5.1.8. Lyd stopper å virke

I noen tilfeller så kan det hende at lydsystemet ikke virker etter oppgraderingen. Hvis dette er tilfellet, så se om denne sjekklisten for ALSA løser ditt problem:

  • Kjør alsaconf som brukeren root

  • Legg brukeren til i gruppa audio

  • Husk å skru opp volumet på lydkortet, og aktiver det ved å ta bort mute (bruk alsamixer)

  • Pass på at arts og esound ikke er aktive

  • Pass på at ingen OSS moduler er lastet

  • Pass på at høyttalerene faktisk er skrudd på

  • Sjekk om kommandoen

    cat /dev/urandom > /dev/audio

    or the command

    speaker-test

    virker for brukeren root.

5.2. NFS monteringer håndters nå av nfs-common

Fra og med versjon 2.13 av util-linux så håndteres ikke lenger NFS-monteringer av util-linux, men av nfs-common. Fordi ikke alle systemer har NFS-monteringer, og for å unngå at portmap installeres unødig, så bare anbefaler pakken util-linux at pakken nfs-common skal installeres. Hvis du trenger å montere NFS-monteringer, så pass på at du har pakken nfs-common installert. Installasjonsskriptet til pakken mount sjekker hvorvidt NFS-monteringer finnes, og avbryter hvis fila /usr/sbin/mount.nfs fra nfs-common ikke er tilstede, eller hvis pakken nfs-common er utdatert. Enten så må du oppgradere nfs-common eller avmontere alle NFS-monteringer før du oppgraderer pakken mount.

5.3. Endringer i rumensk(ro) tastaturoppsett

På grunn av oppgraderingen av xkb-data til versjon 1.3 i lenny så vil standard rumensk (ro) tastatur oppsett nå lage det korrekte tegnet șț (med komma under) istedenfor şţ (med cedilj under). Noen konfigurasjonsvarianter har fått nytt navn, selv om de gamle navnene fortsatt virker, så oppfordres det å oppdatere /etc/X11/xorg.conf med de nye navnene. Mer info om mulig problem på grunn av denne endringen finnes på wiki (kun på rumensk).

5.4. Oppgradere apache2

Standardinnstillingene til apache2 har endret seg litt, noe som kan medføre at du manuelt på gjøre noen endringer i din konfigurasjon. De viktigste endringene er:

NameVirtualHost * har blitt endret til NameVirtualHost *:80. Om du har lagt til flere navnbaserte virtuelle verter, så må du endre <VirtualHost *> til <VirtualHost *:80> for dem alle.

Apache sin User og Group og stien til PidFile er nå konfigurert i /etc/apache2/envvars. Hvis du har endret disse verdiene fra sin standardverdi, så må du endre denne fila. Dette betyr at du ikke kan starte apache2 omigjen med kommandoen apache2 -k start, men at du nå må bruke /etc/init.d/apache2 ellerapache2ctl.

Hjelpeprogrammet suexec som trengs for mod_suexec er nå pakket i en egen pakke, apache2-suexec, denne blir som standard ikke installert.

Modulspesifikke innstillinger har blitt flyttet fra /etc/apache2/apache2.conf til /etc/apache2/mods-available/*.conf.

For mer informasjon se /usr/share/doc/apache2.2-common/NEWS.Debian.gz og /usr/share/doc/apache2.2-common/README.Debian.gz.

5.5. NIS og Network Manager

Versjonen av ypbind som finnes i nis i lenny inneholder støtte for Network Manager. Denne støtten for Network Manager innebærer at ypbind skrur av NIS-klientfunksjonalitet når Network Manager rapporterer at datamaskinen er uten nettverk. Siden Network Manager ofte rapporter at datamaskinen er uten nettverk når nettverket ikke brukes, så bør NIS-brukere med NIS-klientsystemer sørge for at støtten for Network Manager er skrudd av.

Dette kan gjøres enten ved å fjerne pakken network-manager eller ved å redigere fila /etc/default/nis ved å legge til -no-dbus til YPBINDARGS.

Bruken av -no-dbus er standard for nye installasjoner av Debian, men det var ikke slik i tidligere versjoner.

5.6. Sikkerhetsstatus for Mozillaprodukter

Mozillaprogrammene firefox, thunderbird, og sunbird (som har fått andre navn i Debian, henholdsvis iceweasel, icedove, og iceowl, ) er viktige for mange brukere. Dessverre så er hovedforfatterenes holdning angående sikkerhetsoppdateringer, at brukerene hele tiden skal oppgradere til siste versjon av disse produktene, denne holdningen er ikke forenelig med Debian sine regler for sikkerhetsoppdateringer, som sier at man ikke skal blande sammen sikkerthetsoppgraderinger med større funksjonsendringer i programvaren. Vi kan ikke si med sikkerhet i dag, men det kan komme til å skje i løpet av levetiden til lenny at Debian Security Team kommer til den konklusjon at det ikke lenger er mulig å tilby sikkerhetsoppgraderinger for Mozilla produktene. Du bør ta høyde for dette når du implementerer bruken av disse Mozilla produktene, og vurdere andre alternativer som er tilgjengelige i Debian, om du er opptatt av å kunne ha sikkerhetsoppgraderinger.

iceape, versjonen av seamonkey uten varemerker, har blitt tatt ut av lenny (med unntak av noen nødvendige bibliotketspakker).

5.7. Security status of OCS Inventory and SQL-Ledger

The webservice packages ocsinventory-server and sql-ledger are included in the lenny release but have special security requirements that users should be aware of before deploying them. These two webservices are designed for deployment only behind an authenticated HTTP zone and should never be made available to untrusted users; and therefore they receive only limited security support from the Debian security team. Users should therefore take particular care when evaluating who to grant access to these services.

5.8. KDE skrivbordet

Det er ikke noen større endringer i skrivebordsmiljøet KDE. Lenny inneholder en serviceversjon av KDE, som blant annet inneholder oppdaterte oversettelser, versjonen er en blanding av KDE 3.5.9 og KDE 3.5.10. Noen moduler er merket som versjon 3.5.9, men de har endringer inkludert for å passe sammen med versjon 3.5.10. I all hovedsak så er det versjon 3.5.10 som følger med Lenny, men uten endringene i kdebase for kicker, og noen feilfikser i kdepim.

Lenny kommer til å være den siste stabile utgaven som inneholder KDE3.

5.9. Støtte og endringer i Gnome skrivebordet

Det har skjedd mange forandringer i skrivebordsmiljøet GNOME side den versjonen som ble levert med etch. Du finner mer informasjon på GNOME 2.22 Release Notes.

5.10. Ingen støtte for Unicode som standard i emacs21*

Emacs21 and emacs21-nox are not configured to use Unicode by default. For more information and a workaround please see bug #419490. Consider switching to emacs22, emacs22-gtk, or emacs22-nox.

5.11. slurpd/replica vil ikke lenger fungere

OpenLDAP har fra versjone 2.4.7 ikke lenger støtte for LDAP replikering via slurpd. Eksisterende konfigurasjoner må tilpasses den nye LDAP Sync Replication engine (syncrepl). Mer informasjon finnes på http://www.openldap.org/doc/admin24/replication.html.

5.12. Skrivebordet bruker ikke hele skjermen

Driveren for Intel Mobile GM965 kan feilaktig oppdage en VGA utgang, og derfor sette for lav størrelse på skjermen for å kompensere for dette. Symptomet på dette er at bare deler av skjermen blir brukt av vindusbehandleren. Du kan rette opp denne feilen ved å legge til disse linjene i fila /etc/X11/xorg.conf:

Section "Monitor"
  Identifier "VGA"
  Option "Ignore" "true"
EndSection

Please refer to the bug #496169 for more informations.

5.13. DHCP problemer med feiltoleranse

Når et par med servere kjører som DHCP-servere, så må servernavnene være konsekvente, ellers krasjer DHCP

Please see bug #513506 and https://lists.isc.org/pipermail/dhcp-users/2007-September/004538.html for more information.

5.14. VServer Disk Limit

To use the disk limit feature of vserver in lenny, you should use the mount option tag (instead of tagxid in etch).

You should manually update /etc/fstab and/or any script which uses tagxid. Otherwise, the partition will not be mounted and thus the vservers will not start.