附录 A. 在升级前管理您的 stretch 系统

目录

A.1. 升级您的 stretch 系统
A.2. 检查您的 APT source-list 文件
A.3. 删除过时的配置文件
A.4. 将旧版区域设置升级为 UTF-8

本附录包含在升级到 buster 之前,如何确保您能够从 stretch 安装或升级软件包的相关信息。这应该只在特定的情况下需要。

A.1. 升级您的 stretch 系统

基本上这和您之前已经做过的 stretch 系统升级没有什么区别。唯一的区别就是,您首先需要确定您的软件包列表仍旧引用 stretch ,就像在第 A.2 节 “检查您的 APT source-list 文件”中说明的那样。

如果您从 Debian 镜像升级,将自动升级到最新的 stretch 的小版本更新。

A.2. 检查您的 APT source-list 文件

如果您的 APT source-list 文件(参见 sources.list(5))包含了 stable 这样的字符串,它在新的稳定版本发布后实际上已经指向了 buster。如果您还没准备好升级系统的话,这可能不是您想要的结果。但如果您已经运行过了 apt update 命令的话,您仍然可以采取下述步骤退回原状态而不产生额外问题。

如果您已经从 buster 安装了软件包,就没有太大的必要再从 stretch 安装软件包了。在这种情况下,您必须决定是否继续或者终止。降级软件包是可能的,但是不属于本文的讨论范围。

以 root 权限身份用您喜欢的编辑器打开 APT source-list 文件(/etc/apt/sources.list),检查所有以 deb http:deb https:deb tor+http:deb tor+https:URIs: http:URIs: https:URIs: tor+http:URIs: tor+https: 开头,引用 stable 的行。如果找到了,将 stable 改为 stretch

如果有些行以 deb file:URIs: file: 开始,您应该自己检查该位置是否包含有 stretch 或者 buster 的档案仓库。

[重要]重要

不要修改任何以 deb cdrom:URIs: cdrom: 开始的行。如果这样做了的话,这些行就会失效,您将需要重新运行 apt-cdrom 命令以启用从光盘更新的功能。即使在 cdrom: 的行发现 unstable 这样的字符串也不要感到奇怪。虽然令人困惑,但这是正常的。

如果做了任何修改,保存文件后执行

# apt update

以刷新软件包列表。

A.3. 删除过时的配置文件

在将系统升级到 buster 之前,建议从系统中删除旧的配置文件(例如 /etc 下的 *.dpkg-{new,old} 文件)。

A.4. 将旧版区域设置升级为 UTF-8

使用陈旧的非 UTF-8 区域语言设置(locale)已有很长时间不受各类桌面环境和各个主流软件项目的支持。应当运行 dpkg-reconfigure locales 命令以更新并选择默认使用 UTF-8。您也应当确保用户不会覆盖默认设置并在他们的环境中使用陈旧的区域语言设置。