Bulletin d'alerte Debian

DSA-165-1 postgresql -- Dépassements de tampon

Date du rapport :
12 septembre 2002
Paquets concernés :
postgresql
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le dictionnaire CVE du Mitre : CVE-2002-0972, CVE-2002-1398, CVE-2002-1400, CVE-2002-1401, CVE-2002-1402.
Plus de précisions :

Mordred Labs et d'autres ont trouvé des vulnérabilités dans PostgreSQL, un moteur de base de données SQL objet et relationnel. Elles sont basées sur des dépassements d'entier ou de tampon. Spécialement suspects, les longues dates et heures, monnaies, données répétées et les noms longs de zone horaire pouvaient planter le serveur de PostgreSQL ainsi que les données d'entrée de lpad() et de rpad(). D'autres débordements furent trouvés dans circle_poly(), path_encode() et path_addr().

Sauf pour ces trois dernières fonctions, ces problèmes sont réglés dans le source original version 7.2.2 de PostgreSQL dont l'utilisation est recommandée.

La plupart de ces soucis n'existe pas dans la version contenue dans potato de Debian vu que les fonctionnalités ne sont pas implantées. Cependant, PostgreSQL 6.5.3 est assez vieux et il peut contenir des risques bien pires et ils pourraient atteindre à l'intégrité de vos données.

Nous vous conseillons de ne plus utiliser cette version et de mettre jour votre système avec la Debian 3.0 incluant PostgreSQL 7.2.1 à la place, où de nombreux bogues sont corrigés et de nouvelles capacités améliorent la compatibilité avec les standards SQL.

Si vous envisagez une mise à jour, sauvegardez toutes vos bases de données sur votre système avec l'utilitaire pg_dumpall. Prenez en considération le fait que cette version plus récente est plus stricte dans sa gestion des entrées. Ceci signifie que des tests comme "foo = NULL" qui ne sont pas valides ne seront plus acceptés. Aussi en utilisant l'encodage UNICODE, ceux ISO 8859-1 et ISO 8859-15 ne sont plus valides pour les relations. Vous devez donc convertir l'image sauvegardée en utilisant recode latin1..utf-16.

Ces problèmes sont corrigés dans la version 7.2.1-2woody2 pour l'actuelle distribution stable (woody) et celle 7.2.2-2 pour la distribution instable (sid). L'ancienne distribution stable (potato) n'est que partiellement affecté et nous offrons une version 6.5.3-27.2 corrigée de ce paquet.

Nous vous recommandons de mettre à jour vos paquets PostgreSQL.

Corrigé dans :

Debian GNU/Linux 2.2 (potato)

Source :
http://security.debian.org/pool/updates/main/p/postgresql/postgresql_6.5.3-27.2.dsc
http://security.debian.org/pool/updates/main/p/postgresql/postgresql_6.5.3-27.2.diff.gz
http://security.debian.org/pool/updates/main/p/postgresql/postgresql_6.5.3.orig.tar.gz
Composant indépendant de l'architecture :
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-doc_6.5.3-27.2_all.deb
Alpha:
http://security.debian.org/pool/updates/main/p/postgresql/ecpg_6.5.3-27.2_alpha.deb
http://security.debian.org/pool/updates/main/p/postgresql/libpgperl_6.5.3-27.2_alpha.deb
http://security.debian.org/pool/updates/main/p/postgresql/libpgsql2_6.5.3-27.2_alpha.deb
http://security.debian.org/pool/updates/main/p/postgresql/libpgtcl_6.5.3-27.2_alpha.deb
http://security.debian.org/pool/updates/main/p/postgresql/odbc-postgresql_6.5.3-27.2_alpha.deb
http://security.debian.org/pool/updates/main/p/postgresql/pgaccess_6.5.3-27.2_alpha.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql_6.5.3-27.2_alpha.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-client_6.5.3-27.2_alpha.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-contrib_6.5.3-27.2_alpha.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-dev_6.5.3-27.2_alpha.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-pl_6.5.3-27.2_alpha.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-test_6.5.3-27.2_alpha.deb
http://security.debian.org/pool/updates/main/p/postgresql/python-pygresql_6.5.3-27.2_alpha.deb
ARM:
http://security.debian.org/pool/updates/main/p/postgresql/ecpg_6.5.3-27.2_arm.deb
http://security.debian.org/pool/updates/main/p/postgresql/libpgperl_6.5.3-27.2_arm.deb
http://security.debian.org/pool/updates/main/p/postgresql/libpgsql2_6.5.3-27.2_arm.deb
http://security.debian.org/pool/updates/main/p/postgresql/libpgtcl_6.5.3-27.2_arm.deb
http://security.debian.org/pool/updates/main/p/postgresql/odbc-postgresql_6.5.3-27.2_arm.deb
http://security.debian.org/pool/updates/main/p/postgresql/pgaccess_6.5.3-27.2_arm.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql_6.5.3-27.2_arm.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-client_6.5.3-27.2_arm.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-contrib_6.5.3-27.2_arm.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-dev_6.5.3-27.2_arm.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-pl_6.5.3-27.2_arm.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-test_6.5.3-27.2_arm.deb
http://security.debian.org/pool/updates/main/p/postgresql/python-pygresql_6.5.3-27.2_arm.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/p/postgresql/ecpg_6.5.3-27.2_i386.deb
http://security.debian.org/pool/updates/main/p/postgresql/libpgperl_6.5.3-27.2_i386.deb
http://security.debian.org/pool/updates/main/p/postgresql/libpgsql2_6.5.3-27.2_i386.deb
http://security.debian.org/pool/updates/main/p/postgresql/libpgtcl_6.5.3-27.2_i386.deb
http://security.debian.org/pool/updates/main/p/postgresql/odbc-postgresql_6.5.3-27.2_i386.deb
http://security.debian.org/pool/updates/main/p/postgresql/pgaccess_6.5.3-27.2_i386.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql_6.5.3-27.2_i386.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-client_6.5.3-27.2_i386.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-contrib_6.5.3-27.2_i386.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-dev_6.5.3-27.2_i386.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-pl_6.5.3-27.2_i386.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-test_6.5.3-27.2_i386.deb
http://security.debian.org/pool/updates/main/p/postgresql/python-pygresql_6.5.3-27.2_i386.deb
Motorola 680x0:
http://security.debian.org/pool/updates/main/p/postgresql/ecpg_6.5.3-27.2_m68k.deb
http://security.debian.org/pool/updates/main/p/postgresql/libpgperl_6.5.3-27.2_m68k.deb
http://security.debian.org/pool/updates/main/p/postgresql/libpgsql2_6.5.3-27.2_m68k.deb
http://security.debian.org/pool/updates/main/p/postgresql/libpgtcl_6.5.3-27.2_m68k.deb
http://security.debian.org/pool/updates/main/p/postgresql/odbc-postgresql_6.5.3-27.2_m68k.deb
http://security.debian.org/pool/updates/main/p/postgresql/pgaccess_6.5.3-27.2_m68k.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql_6.5.3-27.2_m68k.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-client_6.5.3-27.2_m68k.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-contrib_6.5.3-27.2_m68k.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-dev_6.5.3-27.2_m68k.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-pl_6.5.3-27.2_m68k.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-test_6.5.3-27.2_m68k.deb
http://security.debian.org/pool/updates/main/p/postgresql/python-pygresql_6.5.3-27.2_m68k.deb
PowerPC:
http://security.debian.org/pool/updates/main/p/postgresql/ecpg_6.5.3-27.2_powerpc.deb
http://security.debian.org/pool/updates/main/p/postgresql/libpgperl_6.5.3-27.2_powerpc.deb
http://security.debian.org/pool/updates/main/p/postgresql/libpgsql2_6.5.3-27.2_powerpc.deb
http://security.debian.org/pool/updates/main/p/postgresql/libpgtcl_6.5.3-27.2_powerpc.deb
http://security.debian.org/pool/updates/main/p/postgresql/odbc-postgresql_6.5.3-27.2_powerpc.deb
http://security.debian.org/pool/updates/main/p/postgresql/pgaccess_6.5.3-27.2_powerpc.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql_6.5.3-27.2_powerpc.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-client_6.5.3-27.2_powerpc.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-contrib_6.5.3-27.2_powerpc.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-dev_6.5.3-27.2_powerpc.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-pl_6.5.3-27.2_powerpc.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-test_6.5.3-27.2_powerpc.deb
http://security.debian.org/pool/updates/main/p/postgresql/python-pygresql_6.5.3-27.2_powerpc.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/p/postgresql/ecpg_6.5.3-27.2_sparc.deb
http://security.debian.org/pool/updates/main/p/postgresql/libpgperl_6.5.3-27.2_sparc.deb
http://security.debian.org/pool/updates/main/p/postgresql/libpgsql2_6.5.3-27.2_sparc.deb
http://security.debian.org/pool/updates/main/p/postgresql/libpgtcl_6.5.3-27.2_sparc.deb
http://security.debian.org/pool/updates/main/p/postgresql/odbc-postgresql_6.5.3-27.2_sparc.deb
http://security.debian.org/pool/updates/main/p/postgresql/pgaccess_6.5.3-27.2_sparc.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql_6.5.3-27.2_sparc.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-client_6.5.3-27.2_sparc.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-contrib_6.5.3-27.2_sparc.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-dev_6.5.3-27.2_sparc.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-pl_6.5.3-27.2_sparc.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-test_6.5.3-27.2_sparc.deb
http://security.debian.org/pool/updates/main/p/postgresql/python-pygresql_6.5.3-27.2_sparc.deb

Debian GNU/Linux 3.0 (woody)

Source :
http://security.debian.org/pool/updates/main/p/postgresql/postgresql_7.2.1-2woody2.dsc
http://security.debian.org/pool/updates/main/p/postgresql/postgresql_7.2.1-2woody2.diff.gz
http://security.debian.org/pool/updates/main/p/postgresql/postgresql_7.2.1.orig.tar.gz
Composant indépendant de l'architecture :
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-doc_7.2.1-2woody2_all.deb
Alpha:
http://security.debian.org/pool/updates/main/c/courier-ssl/courier-authpostgresql_0.37.3-3.1_alpha.deb
http://security.debian.org/pool/updates/main/p/postgresql/libecpg3_7.2.1-2woody2_alpha.deb
http://security.debian.org/pool/updates/main/p/postgresql/libpgperl_7.2.1-2woody2_alpha.deb
http://security.debian.org/pool/updates/main/p/postgresql/libpgsql2_7.2.1-2woody2_alpha.deb
http://security.debian.org/pool/updates/main/p/postgresql/libpgtcl_7.2.1-2woody2_alpha.deb
http://security.debian.org/pool/updates/main/p/postgresql/odbc-postgresql_7.2.1-2woody2_alpha.deb
http://security.debian.org/pool/updates/main/p/postgresql/pgaccess_7.2.1-2woody2_alpha.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql_7.2.1-2woody2_alpha.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-client_7.2.1-2woody2_alpha.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-contrib_7.2.1-2woody2_alpha.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-dev_7.2.1-2woody2_alpha.deb
http://security.debian.org/pool/updates/main/p/postgresql/python-pygresql_7.2.1-2woody2_alpha.deb
ARM:
http://security.debian.org/pool/updates/main/c/courier-ssl/courier-authpostgresql_0.37.3-3.1_arm.deb
http://security.debian.org/pool/updates/main/p/postgresql/libecpg3_7.2.1-2woody2_arm.deb
http://security.debian.org/pool/updates/main/p/postgresql/libpgperl_7.2.1-2woody2_arm.deb
http://security.debian.org/pool/updates/main/p/postgresql/libpgsql2_7.2.1-2woody2_arm.deb
http://security.debian.org/pool/updates/main/p/postgresql/libpgtcl_7.2.1-2woody2_arm.deb
http://security.debian.org/pool/updates/main/p/postgresql/odbc-postgresql_7.2.1-2woody2_arm.deb
http://security.debian.org/pool/updates/main/p/postgresql/pgaccess_7.2.1-2woody2_arm.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql_7.2.1-2woody2_arm.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-client_7.2.1-2woody2_arm.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-contrib_7.2.1-2woody2_arm.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-dev_7.2.1-2woody2_arm.deb
http://security.debian.org/pool/updates/main/p/postgresql/python-pygresql_7.2.1-2woody2_arm.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/c/courier-ssl/courier-authpostgresql_0.37.3-3.1_i386.deb
http://security.debian.org/pool/updates/main/p/postgresql/libecpg3_7.2.1-2woody2_i386.deb
http://security.debian.org/pool/updates/main/p/postgresql/libpgperl_7.2.1-2woody2_i386.deb
http://security.debian.org/pool/updates/main/p/postgresql/libpgsql2_7.2.1-2woody2_i386.deb
http://security.debian.org/pool/updates/main/p/postgresql/libpgtcl_7.2.1-2woody2_i386.deb
http://security.debian.org/pool/updates/main/p/postgresql/odbc-postgresql_7.2.1-2woody2_i386.deb
http://security.debian.org/pool/updates/main/p/postgresql/pgaccess_7.2.1-2woody2_i386.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql_7.2.1-2woody2_i386.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-client_7.2.1-2woody2_i386.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-contrib_7.2.1-2woody2_i386.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-dev_7.2.1-2woody2_i386.deb
http://security.debian.org/pool/updates/main/p/postgresql/python-pygresql_7.2.1-2woody2_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/c/courier-ssl/courier-authpostgresql_0.37.3-3.1_ia64.deb
http://security.debian.org/pool/updates/main/p/postgresql/libecpg3_7.2.1-2woody2_ia64.deb
http://security.debian.org/pool/updates/main/p/postgresql/libpgperl_7.2.1-2woody2_ia64.deb
http://security.debian.org/pool/updates/main/p/postgresql/libpgsql2_7.2.1-2woody2_ia64.deb
http://security.debian.org/pool/updates/main/p/postgresql/libpgtcl_7.2.1-2woody2_ia64.deb
http://security.debian.org/pool/updates/main/p/postgresql/odbc-postgresql_7.2.1-2woody2_ia64.deb
http://security.debian.org/pool/updates/main/p/postgresql/pgaccess_7.2.1-2woody2_ia64.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql_7.2.1-2woody2_ia64.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-client_7.2.1-2woody2_ia64.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-contrib_7.2.1-2woody2_ia64.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-dev_7.2.1-2woody2_ia64.deb
http://security.debian.org/pool/updates/main/p/postgresql/python-pygresql_7.2.1-2woody2_ia64.deb
HP Precision:
http://security.debian.org/pool/updates/main/c/courier-ssl/courier-authpostgresql_0.37.3-3.1_hppa.deb
http://security.debian.org/pool/updates/main/p/postgresql/libecpg3_7.2.1-2woody2_hppa.deb
http://security.debian.org/pool/updates/main/p/postgresql/libpgperl_7.2.1-2woody2_hppa.deb
http://security.debian.org/pool/updates/main/p/postgresql/libpgsql2_7.2.1-2woody2_hppa.deb
http://security.debian.org/pool/updates/main/p/postgresql/libpgtcl_7.2.1-2woody2_hppa.deb
http://security.debian.org/pool/updates/main/p/postgresql/odbc-postgresql_7.2.1-2woody2_hppa.deb
http://security.debian.org/pool/updates/main/p/postgresql/pgaccess_7.2.1-2woody2_hppa.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql_7.2.1-2woody2_hppa.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-client_7.2.1-2woody2_hppa.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-contrib_7.2.1-2woody2_hppa.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-dev_7.2.1-2woody2_hppa.deb
http://security.debian.org/pool/updates/main/p/postgresql/python-pygresql_7.2.1-2woody2_hppa.deb
Motorola 680x0:
http://security.debian.org/pool/updates/main/c/courier-ssl/courier-authpostgresql_0.37.3-3.1_m68k.deb
http://security.debian.org/pool/updates/main/p/postgresql/libecpg3_7.2.1-2woody2_m68k.deb
http://security.debian.org/pool/updates/main/p/postgresql/libpgperl_7.2.1-2woody2_m68k.deb
http://security.debian.org/pool/updates/main/p/postgresql/libpgsql2_7.2.1-2woody2_m68k.deb
http://security.debian.org/pool/updates/main/p/postgresql/libpgtcl_7.2.1-2woody2_m68k.deb
http://security.debian.org/pool/updates/main/p/postgresql/odbc-postgresql_7.2.1-2woody2_m68k.deb
http://security.debian.org/pool/updates/main/p/postgresql/pgaccess_7.2.1-2woody2_m68k.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql_7.2.1-2woody2_m68k.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-client_7.2.1-2woody2_m68k.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-contrib_7.2.1-2woody2_m68k.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-dev_7.2.1-2woody2_m68k.deb
http://security.debian.org/pool/updates/main/p/postgresql/python-pygresql_7.2.1-2woody2_m68k.deb
Big endian MIPS:
http://security.debian.org/pool/updates/main/c/courier-ssl/courier-authpostgresql_0.37.3-3.1_mips.deb
http://security.debian.org/pool/updates/main/p/postgresql/libecpg3_7.2.1-2woody2_mips.deb
http://security.debian.org/pool/updates/main/p/postgresql/libpgperl_7.2.1-2woody2_mips.deb
http://security.debian.org/pool/updates/main/p/postgresql/libpgsql2_7.2.1-2woody2_mips.deb
http://security.debian.org/pool/updates/main/p/postgresql/libpgtcl_7.2.1-2woody2_mips.deb
http://security.debian.org/pool/updates/main/p/postgresql/odbc-postgresql_7.2.1-2woody2_mips.deb
http://security.debian.org/pool/updates/main/p/postgresql/pgaccess_7.2.1-2woody2_mips.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql_7.2.1-2woody2_mips.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-client_7.2.1-2woody2_mips.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-contrib_7.2.1-2woody2_mips.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-dev_7.2.1-2woody2_mips.deb
http://security.debian.org/pool/updates/main/p/postgresql/python-pygresql_7.2.1-2woody2_mips.deb
Little endian MIPS:
http://security.debian.org/pool/updates/main/c/courier-ssl/courier-authpostgresql_0.37.3-3.1_mipsel.deb
http://security.debian.org/pool/updates/main/p/postgresql/libecpg3_7.2.1-2woody2_mipsel.deb
http://security.debian.org/pool/updates/main/p/postgresql/libpgperl_7.2.1-2woody2_mipsel.deb
http://security.debian.org/pool/updates/main/p/postgresql/libpgsql2_7.2.1-2woody2_mipsel.deb
http://security.debian.org/pool/updates/main/p/postgresql/libpgtcl_7.2.1-2woody2_mipsel.deb
http://security.debian.org/pool/updates/main/p/postgresql/odbc-postgresql_7.2.1-2woody2_mipsel.deb
http://security.debian.org/pool/updates/main/p/postgresql/pgaccess_7.2.1-2woody2_mipsel.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql_7.2.1-2woody2_mipsel.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-client_7.2.1-2woody2_mipsel.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-contrib_7.2.1-2woody2_mipsel.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-dev_7.2.1-2woody2_mipsel.deb
http://security.debian.org/pool/updates/main/p/postgresql/python-pygresql_7.2.1-2woody2_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/c/courier-ssl/courier-authpostgresql_0.37.3-3.1_powerpc.deb
http://security.debian.org/pool/updates/main/p/postgresql/libecpg3_7.2.1-2woody2_powerpc.deb
http://security.debian.org/pool/updates/main/p/postgresql/libpgperl_7.2.1-2woody2_powerpc.deb
http://security.debian.org/pool/updates/main/p/postgresql/libpgsql2_7.2.1-2woody2_powerpc.deb
http://security.debian.org/pool/updates/main/p/postgresql/libpgtcl_7.2.1-2woody2_powerpc.deb
http://security.debian.org/pool/updates/main/p/postgresql/odbc-postgresql_7.2.1-2woody2_powerpc.deb
http://security.debian.org/pool/updates/main/p/postgresql/pgaccess_7.2.1-2woody2_powerpc.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql_7.2.1-2woody2_powerpc.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-client_7.2.1-2woody2_powerpc.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-contrib_7.2.1-2woody2_powerpc.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-dev_7.2.1-2woody2_powerpc.deb
http://security.debian.org/pool/updates/main/p/postgresql/python-pygresql_7.2.1-2woody2_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/c/courier-ssl/courier-authpostgresql_0.37.3-3.1_s390.deb
http://security.debian.org/pool/updates/main/p/postgresql/libecpg3_7.2.1-2woody2_s390.deb
http://security.debian.org/pool/updates/main/p/postgresql/libpgperl_7.2.1-2woody2_s390.deb
http://security.debian.org/pool/updates/main/p/postgresql/libpgsql2_7.2.1-2woody2_s390.deb
http://security.debian.org/pool/updates/main/p/postgresql/libpgtcl_7.2.1-2woody2_s390.deb
http://security.debian.org/pool/updates/main/p/postgresql/odbc-postgresql_7.2.1-2woody2_s390.deb
http://security.debian.org/pool/updates/main/p/postgresql/pgaccess_7.2.1-2woody2_s390.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql_7.2.1-2woody2_s390.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-client_7.2.1-2woody2_s390.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-contrib_7.2.1-2woody2_s390.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-dev_7.2.1-2woody2_s390.deb
http://security.debian.org/pool/updates/main/p/postgresql/python-pygresql_7.2.1-2woody2_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/c/courier-ssl/courier-authpostgresql_0.37.3-3.1_sparc.deb
http://security.debian.org/pool/updates/main/p/postgresql/libecpg3_7.2.1-2woody2_sparc.deb
http://security.debian.org/pool/updates/main/p/postgresql/libpgperl_7.2.1-2woody2_sparc.deb
http://security.debian.org/pool/updates/main/p/postgresql/libpgsql2_7.2.1-2woody2_sparc.deb
http://security.debian.org/pool/updates/main/p/postgresql/libpgtcl_7.2.1-2woody2_sparc.deb
http://security.debian.org/pool/updates/main/p/postgresql/odbc-postgresql_7.2.1-2woody2_sparc.deb
http://security.debian.org/pool/updates/main/p/postgresql/pgaccess_7.2.1-2woody2_sparc.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql_7.2.1-2woody2_sparc.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-client_7.2.1-2woody2_sparc.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-contrib_7.2.1-2woody2_sparc.deb
http://security.debian.org/pool/updates/main/p/postgresql/postgresql-dev_7.2.1-2woody2_sparc.deb
http://security.debian.org/pool/updates/main/p/postgresql/python-pygresql_7.2.1-2woody2_sparc.deb

Les sommes MD5 des fichiers indiqués sont disponibles sur la page originale de l'alerte de sécurité.