Alerta de Segurança Debian

DSA-317-1 cupsys -- negação de serviço

Data do Alerta:
11 Jun 2003
Pacotes Afetados:
cupsys
Vulnerável:
Sim
Referência à base de dados de segurança:
Na base de dados do BugTraq (na SecurityFocus): ID BugTraq 7637.
No dicionário CVE do Mitre: CVE-2003-0195.
Informações adicionais:

O servidor de impressão CUPS no Debian é vulnerável a um atacante de negação de serviço quando uma requisição HTTP é recebida sem ter sido adequadamente terminada.

Na atual distribuição estável (woody), este problema foi corrigido na versão 1.1.14-5.

Na antiga distribuição estável (potato), este problema foi corrigido na versão 1.0.4-12.2.

Na distribuição instável (sid), este problema foi corrigido na versão 1.1.19final-1.

Nós recomendamos que você atualize seus pacotes cupsys.

Corrigido em:

Debian GNU/Linux 2.2 (potato)

Fonte:
http://security.debian.org/pool/updates/main/c/cupsys/cupsys_1.0.4-12.2.dsc
http://security.debian.org/pool/updates/main/c/cupsys/cupsys_1.0.4-12.2.diff.gz
http://security.debian.org/pool/updates/main/c/cupsys/cupsys_1.0.4.orig.tar.gz
Alpha:
http://security.debian.org/pool/updates/main/c/cupsys/cupsys_1.0.4-12.2_alpha.deb
http://security.debian.org/pool/updates/main/c/cupsys/cupsys-bsd_1.0.4-12.2_alpha.deb
http://security.debian.org/pool/updates/main/c/cupsys/libcupsys1_1.0.4-12.2_alpha.deb
http://security.debian.org/pool/updates/main/c/cupsys/libcupsys1-dev_1.0.4-12.2_alpha.deb
ARM:
http://security.debian.org/pool/updates/main/c/cupsys/cupsys_1.0.4-12.2_arm.deb
http://security.debian.org/pool/updates/main/c/cupsys/cupsys-bsd_1.0.4-12.2_arm.deb
http://security.debian.org/pool/updates/main/c/cupsys/libcupsys1_1.0.4-12.2_arm.deb
http://security.debian.org/pool/updates/main/c/cupsys/libcupsys1-dev_1.0.4-12.2_arm.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/c/cupsys/cupsys_1.0.4-12.2_i386.deb
http://security.debian.org/pool/updates/main/c/cupsys/cupsys-bsd_1.0.4-12.2_i386.deb
http://security.debian.org/pool/updates/main/c/cupsys/libcupsys1_1.0.4-12.2_i386.deb
http://security.debian.org/pool/updates/main/c/cupsys/libcupsys1-dev_1.0.4-12.2_i386.deb
Motorola 680x0:
http://security.debian.org/pool/updates/main/c/cupsys/cupsys_1.0.4-12.2_m68k.deb
http://security.debian.org/pool/updates/main/c/cupsys/cupsys-bsd_1.0.4-12.2_m68k.deb
http://security.debian.org/pool/updates/main/c/cupsys/libcupsys1_1.0.4-12.2_m68k.deb
http://security.debian.org/pool/updates/main/c/cupsys/libcupsys1-dev_1.0.4-12.2_m68k.deb
PowerPC:
http://security.debian.org/pool/updates/main/c/cupsys/cupsys_1.0.4-12.2_powerpc.deb
http://security.debian.org/pool/updates/main/c/cupsys/cupsys-bsd_1.0.4-12.2_powerpc.deb
http://security.debian.org/pool/updates/main/c/cupsys/libcupsys1_1.0.4-12.2_powerpc.deb
http://security.debian.org/pool/updates/main/c/cupsys/libcupsys1-dev_1.0.4-12.2_powerpc.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/c/cupsys/cupsys_1.0.4-12.2_sparc.deb
http://security.debian.org/pool/updates/main/c/cupsys/cupsys-bsd_1.0.4-12.2_sparc.deb
http://security.debian.org/pool/updates/main/c/cupsys/libcupsys1_1.0.4-12.2_sparc.deb
http://security.debian.org/pool/updates/main/c/cupsys/libcupsys1-dev_1.0.4-12.2_sparc.deb

Debian GNU/Linux 3.0 (woody)

Fonte:
http://security.debian.org/pool/updates/main/c/cupsys/cupsys_1.1.14-5.dsc
http://security.debian.org/pool/updates/main/c/cupsys/cupsys_1.1.14-5.diff.gz
http://security.debian.org/pool/updates/main/c/cupsys/cupsys_1.1.14.orig.tar.gz
Alpha:
http://security.debian.org/pool/updates/main/c/cupsys/cupsys_1.1.14-5_alpha.deb
http://security.debian.org/pool/updates/main/c/cupsys/cupsys-bsd_1.1.14-5_alpha.deb
http://security.debian.org/pool/updates/main/c/cupsys/cupsys-client_1.1.14-5_alpha.deb
http://security.debian.org/pool/updates/main/c/cupsys/cupsys-pstoraster_1.1.14-5_alpha.deb
http://security.debian.org/pool/updates/main/c/cupsys/libcupsys2_1.1.14-5_alpha.deb
http://security.debian.org/pool/updates/main/c/cupsys/libcupsys2-dev_1.1.14-5_alpha.deb
ARM:
http://security.debian.org/pool/updates/main/c/cupsys/cupsys_1.1.14-5_arm.deb
http://security.debian.org/pool/updates/main/c/cupsys/cupsys-bsd_1.1.14-5_arm.deb
http://security.debian.org/pool/updates/main/c/cupsys/cupsys-client_1.1.14-5_arm.deb
http://security.debian.org/pool/updates/main/c/cupsys/cupsys-pstoraster_1.1.14-5_arm.deb
http://security.debian.org/pool/updates/main/c/cupsys/libcupsys2_1.1.14-5_arm.deb
http://security.debian.org/pool/updates/main/c/cupsys/libcupsys2-dev_1.1.14-5_arm.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/c/cupsys/cupsys_1.1.14-5_i386.deb
http://security.debian.org/pool/updates/main/c/cupsys/cupsys-bsd_1.1.14-5_i386.deb
http://security.debian.org/pool/updates/main/c/cupsys/cupsys-client_1.1.14-5_i386.deb
http://security.debian.org/pool/updates/main/c/cupsys/cupsys-pstoraster_1.1.14-5_i386.deb
http://security.debian.org/pool/updates/main/c/cupsys/libcupsys2_1.1.14-5_i386.deb
http://security.debian.org/pool/updates/main/c/cupsys/libcupsys2-dev_1.1.14-5_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/c/cupsys/cupsys_1.1.14-5_ia64.deb
http://security.debian.org/pool/updates/main/c/cupsys/cupsys-bsd_1.1.14-5_ia64.deb
http://security.debian.org/pool/updates/main/c/cupsys/cupsys-client_1.1.14-5_ia64.deb
http://security.debian.org/pool/updates/main/c/cupsys/cupsys-pstoraster_1.1.14-5_ia64.deb
http://security.debian.org/pool/updates/main/c/cupsys/libcupsys2_1.1.14-5_ia64.deb
http://security.debian.org/pool/updates/main/c/cupsys/libcupsys2-dev_1.1.14-5_ia64.deb
HPPA:
http://security.debian.org/pool/updates/main/c/cupsys/cupsys_1.1.14-5_hppa.deb
http://security.debian.org/pool/updates/main/c/cupsys/cupsys-bsd_1.1.14-5_hppa.deb
http://security.debian.org/pool/updates/main/c/cupsys/cupsys-client_1.1.14-5_hppa.deb
http://security.debian.org/pool/updates/main/c/cupsys/cupsys-pstoraster_1.1.14-5_hppa.deb
http://security.debian.org/pool/updates/main/c/cupsys/libcupsys2_1.1.14-5_hppa.deb
http://security.debian.org/pool/updates/main/c/cupsys/libcupsys2-dev_1.1.14-5_hppa.deb
Motorola 680x0:
http://security.debian.org/pool/updates/main/c/cupsys/cupsys_1.1.14-5_m68k.deb
http://security.debian.org/pool/updates/main/c/cupsys/cupsys-bsd_1.1.14-5_m68k.deb
http://security.debian.org/pool/updates/main/c/cupsys/cupsys-client_1.1.14-5_m68k.deb
http://security.debian.org/pool/updates/main/c/cupsys/cupsys-pstoraster_1.1.14-5_m68k.deb
http://security.debian.org/pool/updates/main/c/cupsys/libcupsys2_1.1.14-5_m68k.deb
http://security.debian.org/pool/updates/main/c/cupsys/libcupsys2-dev_1.1.14-5_m68k.deb
Big endian MIPS:
http://security.debian.org/pool/updates/main/c/cupsys/cupsys_1.1.14-5_mips.deb
http://security.debian.org/pool/updates/main/c/cupsys/cupsys-bsd_1.1.14-5_mips.deb
http://security.debian.org/pool/updates/main/c/cupsys/cupsys-client_1.1.14-5_mips.deb
http://security.debian.org/pool/updates/main/c/cupsys/cupsys-pstoraster_1.1.14-5_mips.deb
http://security.debian.org/pool/updates/main/c/cupsys/libcupsys2_1.1.14-5_mips.deb
http://security.debian.org/pool/updates/main/c/cupsys/libcupsys2-dev_1.1.14-5_mips.deb
Little endian MIPS:
http://security.debian.org/pool/updates/main/c/cupsys/cupsys_1.1.14-5_mipsel.deb
http://security.debian.org/pool/updates/main/c/cupsys/cupsys-bsd_1.1.14-5_mipsel.deb
http://security.debian.org/pool/updates/main/c/cupsys/cupsys-client_1.1.14-5_mipsel.deb
http://security.debian.org/pool/updates/main/c/cupsys/cupsys-pstoraster_1.1.14-5_mipsel.deb
http://security.debian.org/pool/updates/main/c/cupsys/libcupsys2_1.1.14-5_mipsel.deb
http://security.debian.org/pool/updates/main/c/cupsys/libcupsys2-dev_1.1.14-5_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/c/cupsys/cupsys_1.1.14-5_powerpc.deb
http://security.debian.org/pool/updates/main/c/cupsys/cupsys-bsd_1.1.14-5_powerpc.deb
http://security.debian.org/pool/updates/main/c/cupsys/cupsys-client_1.1.14-5_powerpc.deb
http://security.debian.org/pool/updates/main/c/cupsys/cupsys-pstoraster_1.1.14-5_powerpc.deb
http://security.debian.org/pool/updates/main/c/cupsys/libcupsys2_1.1.14-5_powerpc.deb
http://security.debian.org/pool/updates/main/c/cupsys/libcupsys2-dev_1.1.14-5_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/c/cupsys/cupsys_1.1.14-5_s390.deb
http://security.debian.org/pool/updates/main/c/cupsys/cupsys-bsd_1.1.14-5_s390.deb
http://security.debian.org/pool/updates/main/c/cupsys/cupsys-client_1.1.14-5_s390.deb
http://security.debian.org/pool/updates/main/c/cupsys/cupsys-pstoraster_1.1.14-5_s390.deb
http://security.debian.org/pool/updates/main/c/cupsys/libcupsys2_1.1.14-5_s390.deb
http://security.debian.org/pool/updates/main/c/cupsys/libcupsys2-dev_1.1.14-5_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/c/cupsys/cupsys_1.1.14-5_sparc.deb
http://security.debian.org/pool/updates/main/c/cupsys/cupsys-bsd_1.1.14-5_sparc.deb
http://security.debian.org/pool/updates/main/c/cupsys/cupsys-client_1.1.14-5_sparc.deb
http://security.debian.org/pool/updates/main/c/cupsys/cupsys-pstoraster_1.1.14-5_sparc.deb
http://security.debian.org/pool/updates/main/c/cupsys/libcupsys2_1.1.14-5_sparc.deb
http://security.debian.org/pool/updates/main/c/cupsys/libcupsys2-dev_1.1.14-5_sparc.deb

Checksums MD5 dos arquivos listados estão disponíveis no alerta original.