Alerta de Segurança Debian

DSA-326-1 orville-write -- buffer overflows

Data do Alerta:
19 Jun 2003
Pacotes Afetados:
orville-write
Vulnerável:
Sim
Referência à base de dados de segurança:
Na base de dados do BugTraq (na SecurityFocus): ID BugTraq 7988.
No dicionário CVE do Mitre: CVE-2003-0441.
Informações adicionais:

Orville Write, uma substituição para o comando padrão write(1), contém um número de estouros de buffer. Esses podem ser explorados para obter tanto gid tty quanto privilégios de root, dependendo da configuração selecionada quando o pacote foi instalado.

Para a distribuição estável (woody) esse problema foi corrigido na versão 2.53-4woody1.

A antiga distribuição estável (potato) não contém o pacote orville-write.

Para a distribuição instável (sid) esse problema será corrigido logo. Veja o Protocolo de Erro #170747 do Debian.

Nós recomendamos que atualize seu pacote orville-write.

Corrigido em:

Debian GNU/Linux 3.0 (woody)

Fonte:
http://security.debian.org/pool/updates/main/o/orville-write/orville-write_2.53-4woody1.dsc
http://security.debian.org/pool/updates/main/o/orville-write/orville-write_2.53-4woody1.diff.gz
http://security.debian.org/pool/updates/main/o/orville-write/orville-write_2.53.orig.tar.gz
Alpha:
http://security.debian.org/pool/updates/main/o/orville-write/orville-write_2.53-4woody1_alpha.deb
ARM:
http://security.debian.org/pool/updates/main/o/orville-write/orville-write_2.53-4woody1_arm.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/o/orville-write/orville-write_2.53-4woody1_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/o/orville-write/orville-write_2.53-4woody1_ia64.deb
HPPA:
http://security.debian.org/pool/updates/main/o/orville-write/orville-write_2.53-4woody1_hppa.deb
Motorola 680x0:
http://security.debian.org/pool/updates/main/o/orville-write/orville-write_2.53-4woody1_m68k.deb
Big endian MIPS:
http://security.debian.org/pool/updates/main/o/orville-write/orville-write_2.53-4woody1_mips.deb
Little endian MIPS:
http://security.debian.org/pool/updates/main/o/orville-write/orville-write_2.53-4woody1_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/o/orville-write/orville-write_2.53-4woody1_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/o/orville-write/orville-write_2.53-4woody1_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/o/orville-write/orville-write_2.53-4woody1_sparc.deb

Checksums MD5 dos arquivos listados estão disponíveis no alerta original.