Debian セキュリティ勧告

DSA-347-1 teapop -- SQL インジェクション

報告日時:
2003-07-08
影響を受けるパッケージ:
teapop
危険性:
あり
参考セキュリティデータベース:
(SecurityFocus の) Bugtraq データベース: BugTraq ID 8146.
Mitre の CVE 辞書: CVE-2003-0515.
詳細:

POP-3 サーバの teapop には、PostgreSQL や MySQL データベースに対してユーザの認証を行うモジュールが含まれます。 このモジュールはユーザが提供した文字列を SQL クエリに使用する前に適切にエスケープを行っていません。 この脆弱性を悪用して、teapop が認証したデータベースユーザの権限で任意の SQL コードを実行することが可能です。

安定版 (stable) ディストリビューション (woody) では、この問題はバージョン 0.3.4-1woody2 で修正されています。

不安定版 (unstable) ディストリビューション (sid) では、この問題はバージョン 0.3.5-2 で修正されています。

直ちに teapop パッケージを更新することを勧めます。

修正:

Debian GNU/Linux 3.0 (woody)

ソース:
http://security.debian.org/pool/updates/main/t/teapop/teapop_0.3.4-1woody2.dsc
http://security.debian.org/pool/updates/main/t/teapop/teapop_0.3.4-1woody2.diff.gz
http://security.debian.org/pool/updates/main/t/teapop/teapop_0.3.4.orig.tar.gz
Alpha:
http://security.debian.org/pool/updates/main/t/teapop/teapop_0.3.4-1woody2_alpha.deb
http://security.debian.org/pool/updates/main/t/teapop/teapop-mysql_0.3.4-1woody2_alpha.deb
http://security.debian.org/pool/updates/main/t/teapop/teapop-pgsql_0.3.4-1woody2_alpha.deb
ARM:
http://security.debian.org/pool/updates/main/t/teapop/teapop_0.3.4-1woody2_arm.deb
http://security.debian.org/pool/updates/main/t/teapop/teapop-mysql_0.3.4-1woody2_arm.deb
http://security.debian.org/pool/updates/main/t/teapop/teapop-pgsql_0.3.4-1woody2_arm.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/t/teapop/teapop_0.3.4-1woody2_i386.deb
http://security.debian.org/pool/updates/main/t/teapop/teapop-mysql_0.3.4-1woody2_i386.deb
http://security.debian.org/pool/updates/main/t/teapop/teapop-pgsql_0.3.4-1woody2_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/t/teapop/teapop_0.3.4-1woody2_ia64.deb
http://security.debian.org/pool/updates/main/t/teapop/teapop-mysql_0.3.4-1woody2_ia64.deb
http://security.debian.org/pool/updates/main/t/teapop/teapop-pgsql_0.3.4-1woody2_ia64.deb
HPPA:
http://security.debian.org/pool/updates/main/t/teapop/teapop_0.3.4-1woody2_hppa.deb
http://security.debian.org/pool/updates/main/t/teapop/teapop-mysql_0.3.4-1woody2_hppa.deb
http://security.debian.org/pool/updates/main/t/teapop/teapop-pgsql_0.3.4-1woody2_hppa.deb
Motorola 680x0:
http://security.debian.org/pool/updates/main/t/teapop/teapop_0.3.4-1woody2_m68k.deb
http://security.debian.org/pool/updates/main/t/teapop/teapop-mysql_0.3.4-1woody2_m68k.deb
http://security.debian.org/pool/updates/main/t/teapop/teapop-pgsql_0.3.4-1woody2_m68k.deb
Big endian MIPS:
http://security.debian.org/pool/updates/main/t/teapop/teapop_0.3.4-1woody2_mips.deb
http://security.debian.org/pool/updates/main/t/teapop/teapop-mysql_0.3.4-1woody2_mips.deb
http://security.debian.org/pool/updates/main/t/teapop/teapop-pgsql_0.3.4-1woody2_mips.deb
Little endian MIPS:
http://security.debian.org/pool/updates/main/t/teapop/teapop_0.3.4-1woody2_mipsel.deb
http://security.debian.org/pool/updates/main/t/teapop/teapop-mysql_0.3.4-1woody2_mipsel.deb
http://security.debian.org/pool/updates/main/t/teapop/teapop-pgsql_0.3.4-1woody2_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/t/teapop/teapop_0.3.4-1woody2_powerpc.deb
http://security.debian.org/pool/updates/main/t/teapop/teapop-mysql_0.3.4-1woody2_powerpc.deb
http://security.debian.org/pool/updates/main/t/teapop/teapop-pgsql_0.3.4-1woody2_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/t/teapop/teapop_0.3.4-1woody2_s390.deb
http://security.debian.org/pool/updates/main/t/teapop/teapop-mysql_0.3.4-1woody2_s390.deb
http://security.debian.org/pool/updates/main/t/teapop/teapop-pgsql_0.3.4-1woody2_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/t/teapop/teapop_0.3.4-1woody2_sparc.deb
http://security.debian.org/pool/updates/main/t/teapop/teapop-mysql_0.3.4-1woody2_sparc.deb
http://security.debian.org/pool/updates/main/t/teapop/teapop-pgsql_0.3.4-1woody2_sparc.deb

一覧にあるファイルの MD5 チェックサムは勧告の原文にあります。