Debians sikkerhedsbulletin

DSA-362-1 mindi -- usikker midlertidig fil

Rapporteret den:
2. aug 2003
Berørte pakker:
mindi
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Bugtraq-databasen (hos SecurityFocus): BugTraq-id 8332.
I Mitres CVE-ordbog: CVE-2003-0617.
Yderligere oplysninger:

mindi, et program til oprettelse af boot-/root-disketter, tager ikke de nødvendige sikkerhedsforanstaltninger ved oprettelse af midlertidige filer. Denne fejl kunne potentielt udnyttes til at overskrive vilkårlige filer med rettighederne hørende til den bruger, der kører mindi.

I den stabile distribution (woody) er dette problem rettet i version 0.58.r5-1woody1.

I den ustabile distribution (sid) vil dette problem snart blive rettet. Se Debians fejl nummer 203825.

Vi anbefaler at du opdaterer din mindi-pakke.

Rettet i:

Debian GNU/Linux 3.0 (woody)

Kildekode:
http://security.debian.org/pool/updates/main/m/mindi/mindi_0.58.r5-1woody1.dsc
http://security.debian.org/pool/updates/main/m/mindi/mindi_0.58.r5-1woody1.diff.gz
http://security.debian.org/pool/updates/main/m/mindi/mindi_0.58.r5.orig.tar.gz
Intel IA-32:
http://security.debian.org/pool/updates/main/m/mindi/mindi_0.58.r5-1woody1_i386.deb

MD5-kontrolsummer for de listede filer findes i den originale sikkerhedsbulletin.