Säkerhetsbulletin från Debian

DSA-370-1 pam-pgsql -- formatsträng

Rapporterat den:
2003-08-08
Berörda paket:
pam-pgsql
Sårbara:
Ja
Referenser i säkerhetsdatabaser:
I Bugtraq-databasen (hos SecurityFocus): BugTraq-id 8379.
I Mitres CVE-förteckning: CVE-2003-0672.
Ytterligare information:

Florian Zumbiehl rapporterade en sårbarhet i pam-pgsql där användar-id:t som skulle användas till autentisering användes som formatsträng i ett loggmeddelande. Denna sårbarhet kan göra det möjligt för en angripare att exekvera godtycklig kod med privilegierna hos det program som ber om PAM-autentisering.

För den stabila utgåvan (Woody) har detta problem rättats i version 0.5.2-3woody1.

För den instabila utgåvan (Sid) har detta problem rättats i version 0.5.2-7.

Vi rekommenderar att ni uppgraderar ert pam-pgsql-paket.

Rättat i:

Debian GNU/Linux 3.0 (woody)

Källkod:
http://security.debian.org/pool/updates/main/p/pam-pgsql/pam-pgsql_0.5.2-3woody1.dsc
http://security.debian.org/pool/updates/main/p/pam-pgsql/pam-pgsql_0.5.2-3woody1.diff.gz
http://security.debian.org/pool/updates/main/p/pam-pgsql/pam-pgsql_0.5.2.orig.tar.gz
Alpha:
http://security.debian.org/pool/updates/main/p/pam-pgsql/libpam-pgsql_0.5.2-3woody1_alpha.deb
ARM:
http://security.debian.org/pool/updates/main/p/pam-pgsql/libpam-pgsql_0.5.2-3woody1_arm.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/p/pam-pgsql/libpam-pgsql_0.5.2-3woody1_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/p/pam-pgsql/libpam-pgsql_0.5.2-3woody1_ia64.deb
HPPA:
http://security.debian.org/pool/updates/main/p/pam-pgsql/libpam-pgsql_0.5.2-3woody1_hppa.deb
Motorola 680x0:
http://security.debian.org/pool/updates/main/p/pam-pgsql/libpam-pgsql_0.5.2-3woody1_m68k.deb
Big endian MIPS:
http://security.debian.org/pool/updates/main/p/pam-pgsql/libpam-pgsql_0.5.2-3woody1_mips.deb
Little endian MIPS:
http://security.debian.org/pool/updates/main/p/pam-pgsql/libpam-pgsql_0.5.2-3woody1_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/p/pam-pgsql/libpam-pgsql_0.5.2-3woody1_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/p/pam-pgsql/libpam-pgsql_0.5.2-3woody1_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/p/pam-pgsql/libpam-pgsql_0.5.2-3woody1_sparc.deb

MD5-kontrollsummor för dessa filer finns i originalbulletinen.