Debian-Sicherheitsankündigung

DSA-410-1 libnids -- Pufferüberlauf

Datum des Berichts:
05. Jan 2004
Betroffene Pakete:
libnids
Verwundbar:
Ja
Sicherheitsdatenbanken-Referenzen:
In der Bugtraq-Datenbank (bei SecurityFocus): BugTraq ID 8905.
In Mitres CVE-Verzeichnis: CVE-2003-0850.
Weitere Informationen:

In libnids, einer Bibliothek zur Analyse von Netzwerkverkehr, wurde eine Verwundbarkeit entdeckt, durch die sorgfältig angefertigte TCP-Datagramme eine Speicherverletzung verursachen können. Dadurch kann möglicherweise beliebiger Code mit den Rechten des Benutzers, der ein Programm verwendet, das libnids benutzt (wie z.B. dsniff), ausgeführt werden.

Für die aktuelle stable Distribution (Woody) wurde dieses Problem in Version 1.16-3woody1 behoben.

Für die unstable Distribution (Sid) wird dieses Problem bald behoben werden.

Wir empfehlen Ihnen, Ihr libnids-Paket zu aktualisieren.

Behoben in:

Debian GNU/Linux 3.0 (woody)

Quellcode:
http://security.debian.org/pool/updates/main/libn/libnids/libnids_1.16-3woody1.dsc
http://security.debian.org/pool/updates/main/libn/libnids/libnids_1.16-3woody1.diff.gz
http://security.debian.org/pool/updates/main/libn/libnids/libnids_1.16.orig.tar.gz
Alpha:
http://security.debian.org/pool/updates/main/libn/libnids/libnids-dev_1.16-3woody1_alpha.deb
http://security.debian.org/pool/updates/main/libn/libnids/libnids1_1.16-3woody1_alpha.deb
ARM:
http://security.debian.org/pool/updates/main/libn/libnids/libnids-dev_1.16-3woody1_arm.deb
http://security.debian.org/pool/updates/main/libn/libnids/libnids1_1.16-3woody1_arm.deb
Intel IA-32:
http://security.debian.org/pool/updates/main/libn/libnids/libnids-dev_1.16-3woody1_i386.deb
http://security.debian.org/pool/updates/main/libn/libnids/libnids1_1.16-3woody1_i386.deb
Intel IA-64:
http://security.debian.org/pool/updates/main/libn/libnids/libnids-dev_1.16-3woody1_ia64.deb
http://security.debian.org/pool/updates/main/libn/libnids/libnids1_1.16-3woody1_ia64.deb
HPPA:
http://security.debian.org/pool/updates/main/libn/libnids/libnids-dev_1.16-3woody1_hppa.deb
http://security.debian.org/pool/updates/main/libn/libnids/libnids1_1.16-3woody1_hppa.deb
Motorola 680x0:
http://security.debian.org/pool/updates/main/libn/libnids/libnids-dev_1.16-3woody1_m68k.deb
http://security.debian.org/pool/updates/main/libn/libnids/libnids1_1.16-3woody1_m68k.deb
Big endian MIPS:
http://security.debian.org/pool/updates/main/libn/libnids/libnids-dev_1.16-3woody1_mips.deb
http://security.debian.org/pool/updates/main/libn/libnids/libnids1_1.16-3woody1_mips.deb
Little endian MIPS:
http://security.debian.org/pool/updates/main/libn/libnids/libnids-dev_1.16-3woody1_mipsel.deb
http://security.debian.org/pool/updates/main/libn/libnids/libnids1_1.16-3woody1_mipsel.deb
PowerPC:
http://security.debian.org/pool/updates/main/libn/libnids/libnids-dev_1.16-3woody1_powerpc.deb
http://security.debian.org/pool/updates/main/libn/libnids/libnids1_1.16-3woody1_powerpc.deb
IBM S/390:
http://security.debian.org/pool/updates/main/libn/libnids/libnids-dev_1.16-3woody1_s390.deb
http://security.debian.org/pool/updates/main/libn/libnids/libnids1_1.16-3woody1_s390.deb
Sun Sparc:
http://security.debian.org/pool/updates/main/libn/libnids/libnids-dev_1.16-3woody1_sparc.deb
http://security.debian.org/pool/updates/main/libn/libnids/libnids1_1.16-3woody1_sparc.deb

MD5-Prüfsummen der aufgeführten Dateien stehen in der ursprünglichen Sicherheitsankündigung zur Verfügung.